3

I've upgraded my Magento installation from ~1.4 to 1.8 and am having trouble with a package that I am using called Mage Quotes. I had to manually install the files and am getting the following error afterwards:

Fatal error: Class 'Mage_Quotes_Helper_Data' not found in app/Mage.php on line 547

I've found the code referencing the helper like this:

Mage::helper('quotes')->

I have a \app\code\local\Mage\Quotes\Helper\Data.php file:

class Mage_Quotes_Helper_Data extends Mage_Core_Helper_Abstract 
{
   ...
}

Here is my config.xml file:

<config>
<modules>
    <Mage_Quotes>
        <version>0.8.0</version>
    </Mage_Quotes>
</modules>
<frontend>
    <routers>
        <quotes>
            <use>standard</use>
            <args>
                <module>Mage_Quotes</module>
                <frontName>inquire.html</frontName>
            </args>
        </quotes>
    </routers>
    <translate>
        <modules>
            <Mage_Quotes>
                <files>
                    <default>Mage_Quotes.csv</default>
                </files>
            </Mage_Quotes>
        </modules>
    </translate>
    <layout>
        <updates>
            <quote>
                <file>quotes.xml</file>
            </quote>
        </updates>
    </layout>
</frontend>
<global>
    <resources>
        <quotes_setup>
            <setup>
                <module>Mage_Quotes</module>
            </setup>
            <connection>
                <use>core_setup</use>
            </connection>
        </quotes_setup>
    </resources>
    <template>
        <email>
            <quotes_email_email_template translate="label" module="quotes">
                <label>Inquire Form</label>
                <file>quote_form.html</file>
                <type>text</type>
            </quotes_email_email_template>
        </email>
    </template>
</global>

<adminhtml>
    <translate>
        <modules>
            <Mage_Quotes>
                <files>
                    <default>Mage_Quotes.csv</default>
                </files>
            </Mage_Quotes>
        </modules>
    </translate>
    <acl>
        <resources>
            <admin>
                <children>
                    <system>
                        <children>
                            <config>
                                <children>
                                    <quotes>
                                        <title>Quotes Section</title>
                                    </quotes>
                                </children>
                            </config>
                        </children>
                    </system>
                </children>
            </admin>
        </resources>
    </acl>
</adminhtml>

<default>
    <quotes>
        <quotes>
            <enabled>1</enabled>
        </quotes>
        <email>
            <recipient_email><![CDATA[hello@example.com]]></recipient_email>
            <sender_email_identity>custom2</sender_email_identity>
            <email_template>quotes_email_email_template</email_template>
        </email>
    </quotes>
</default>

I've looked at solutions for similar questions and tried them, but haven't been able to resolve the issue.

All caching is disabled and after I make any change to a file I am manually deleting the /var/cache folder before refreshing the page.

Any help is appreciated.

2

As I understand, it is third party extension then you should also mention your helper class in config.xml file too. Like this-

<global>
...
    <helpers>
        <Mage_Quotes>
            <class>Mage_Quotes_Helper</class>
        </Mage_Quotes>
    </helpers>
....
</global>

Hope this helps.

Although I doubt if it is magento core file.

  • I tried adding this exactly and it did not make a difference. Once thing that I have noticed is that if I remove the system.xml file, then I don't see the error in the admin section. Likewise, if I remove the "<reference name="root">" section from my layout file, then I don't see the error and the package actually work. This tells me that the package is not using the helper at all. It's magento core that is requiring it to be there and for some reason isn't finding it. – Sam Heck Jun 3 '15 at 3:09
  • Where did you add it? you should add before your <resources> tag. And which system.xml file are you removing? – Adarsh Khatri Jun 3 '15 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.