2

When I try to save an existing product it takes me to a blank page and the data is not getting saved.It does not happen for all products but only few.It was working fine until last week and haven't installed anything new. I tried error reporting in index and its not showing any errors. I have only system logs and have this warning - not sure its related to my issue.

Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 64: parser error : Start tag expected, '<' not found in /home/magento/public_html/lib/Varien/Simplexml/Config.php on line 510

Current memory limit is 1024

1

If you are certain that you haven't changed anything on your site, here are some things you can try:

  • If using a VCS, run a diff against the head/latest commit to see what was changed
  • If you haven't applied recent security patches (1533, 5344, 5944), you may have been a victim to a hacker who could have modified your code
  • Use a tool like xmllint to locate the malformed XML document, see here for a nice tip on how to do that
  • A white screen is usually an indicator of memory exhaustion or a fatal exception that was not caught. You can temporarily force developer mode or enable the display_errors PHP option and run through again to see error output

Another thing to consider is your catalog size in conjunction with extensions that might scan the catalog on update. For example, I've seen catalog permissions extensions that dramatically affect performance of a store in backend and frontend contexts.

  • Thanks Rick . updated security patches but only after the blank page. But if some one modified the code, should it not get affected to all products page. Can you please explain what you mean by catalog permissions. Have products which I am not using anymore. – alexy456 Jun 2 '15 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.