2

Here is the log for the error

   a:5:{i:0;s:123:"Source model "customeractivation/resource_attribute_source_customeractivation" not found for attribute "customer_activated"";i:1;s:3149:"#0 /home/allholde/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(387): Mage::exception('Mage_Eav', 'Source model "c...')
#1 /home/allholde/public_html/app/code/core/Mage/Adminhtml/Block/Widget/Form.php(201): Mage_Eav_Model_Entity_Attribute_Abstract->getSource()
#2 /home/allholde/public_html/app/code/core/Mage/Adminhtml/Block/Customer/Edit/Tab/Account.php(75): Mage_Adminhtml_Block_Widget_Form->_setFieldset(Array, Object(Varien_Data_Form_Element_Fieldset), Array)
#3 /home/allholde/public_html/app/code/core/Mage/Adminhtml/Block/Customer/Edit/Tabs.php(58): Mage_Adminhtml_Block_Customer_Edit_Tab_Account->initForm()
#4 /home/allholde/public_html/app/code/core/Mage/Core/Block/Abstract.php(918): Mage_Adminhtml_Block_Customer_Edit_Tabs->_beforeToHtml()
#5 /home/allholde/public_html/app/code/core/Mage/Core/Block/Text/List.php(43): Mage_Core_Block_Abstract->toHtml()
#6 /home/allholde/public_html/app/code/core/Mage/Core/Block/Abstract.php(919): Mage_Core_Block_Text_List->_toHtml()
#7 /home/allholde/public_html/app/code/core/Mage/Core/Block/Abstract.php(637): Mage_Core_Block_Abstract->toHtml()
#8 /home/allholde/public_html/app/code/core/Mage/Core/Block/Abstract.php(581): Mage_Core_Block_Abstract->_getChildHtml('left', true)
#9 /home/allholde/public_html/app/design/adminhtml/default/default/template/page.phtml(58): Mage_Core_Block_Abstract->getChildHtml('left')
#10 /home/allholde/public_html/app/code/core/Mage/Core/Block/Template.php(241): include('/home/allholde/...')
#11 /home/allholde/public_html/app/code/core/Mage/Core/Block/Template.php(272): Mage_Core_Block_Template->fetchView('adminhtml/defau...')
#12 /home/allholde/public_html/app/code/core/Mage/Core/Block/Template.php(286): Mage_Core_Block_Template->renderView()
#13 /home/allholde/public_html/app/code/core/Mage/Adminhtml/Block/Template.php(81): Mage_Core_Block_Template->_toHtml()
#14 /home/allholde/public_html/app/code/core/Mage/Core/Block/Abstract.php(919): Mage_Adminhtml_Block_Template->_toHtml()
#15 /home/allholde/public_html/app/code/core/Mage/Core/Model/Layout.php(555): Mage_Core_Block_Abstract->toHtml()
#16 /home/allholde/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(390): Mage_Core_Model_Layout->getOutput()
#17 /home/allholde/public_html/app/code/core/Mage/Adminhtml/controllers/CustomerController.php(151): Mage_Core_Controller_Varien_Action->renderLayout()
#18 /home/allholde/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Adminhtml_CustomerController->editAction()
#19 /home/allholde/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('edit')
#20 /home/allholde/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#21 /home/allholde/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#22 /home/allholde/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#23 /home/allholde/public_html/index.php(130): Mage::run('', 'store')
#24 {main}";s:3:"url";s:79:"/index.php/admin123/customer/edit/id/2388/key/989271bfd789f6f13c18fb5c9969f707/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}

4 Answers 4

1

In your system,there have an eav attribute which Source model does not exits in your db.which source model is customeractivation/resource_attribute_source_customeractivation.

This model class file does not exits in system. This class may be

MOduleNameSpace_MOduleName_Model_Resource_Attribute_Source_Customeractivation

This may be dropdown and multi select attribute .You need to create this attribute from eav_attribute.

Please see about source model at here

1

ok im still not sure the cause or maybe it was an uninstall of an extension but this is how i solved it

deleted the following from table eav_attribute

customeractivation/resource_attribute_source_Customerpayment
customeractivation/resource_attribute_source_Iswebsitelive
customeractivation/resource_attribute_source_StoreType
1

install any customer attribute extension then go admin panel->customer->manage attribute delete attribute code "customer_activated"

0

You seem to be having a similar issue as reported here.

https://github.com/Vinai/customer-activation/issues/74

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.