0

Product image is uploaded succesfully in admin backend, but it doesn't display on frontend product page (404 error).

The image backend url: /media/catalog/product/5/0/50_2_1_4.jpg

Frontend url: /media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/5/0/50_2_1_4.jpg and it doesn't exist on ftp.

If file size less than 1 MB, frontend image uploads ok.

I checked chmod permissions for media and all subfolders - 777.

My server has curl; image gd - enabled; file_uploads - on; upload_max_filesize - 12M; post_max_size - 20M; max_file_uploads - 20; upload_tmp_dir - no value;

I enabled/disabled/updated/flushed magento cache but nothing solved the issue.

Is it possible to remove this limit and how can I do it?

Hope for your help and thanks everyone.

1

Consult your error log for errors, I anticipate you are seeing a memory limit exception.

You will likely need to increase the memory_limit attribute in php.ini from the 1M it appears to be set to, to something more useful.

Mine is set to 512M at this time.

memory_limit = 512M

However, you may find your host has imposed limits, or hiding somewhere in your code is a

ini_set('memory_limit','1M');

Which is overriding the php.ini set value.

In some cases this value can also be set in .htaccess so check there also.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.