Im trying to setup my LIVE Magento repo on localhost (WAMP) and simply can't get the website itself to work. Admin works. Currently I can conclude the following:

  1. Requesting: - the frontpage - does not work, shows "This webpage is not available"
  2. Requesting: - works
  3. Requesting: - works, I can login and see all of my database imported data. Products, users, sales - everything is there.

Symptons noted when I request the frontpage:

  1. Loading spinner "thinks" a lot - the frontpage doesn't give an instant response (so seems it's actually "connecting" to something)
  2. Nothing appears in the console.log
  3. Nothing / no errors appear in var/log or var/report

Any suggestions on what could be causing this?

What I tried - so far:

  1. Ran search and replace DB path values from LIVE site to locahost path via: https://interconnectit.com/products/search-and-replace-for-wordpress-databases/
  2. Read several places using rather than localhost was recommend, so ended up using that
  3. Tried adding set_time_limit(1800); in the start of index.php
  4. In php.ini: set - max_execution_time = 1800
  5. In php.ini: set - max_input_vars = 1800
  6. In php.ini: set - memory_limit = 512M
  7. In php.ini: set - mysql.connect_timeout = -1
  8. Double checkhed In DB Table: core_config_data > web/unsecure/base_url + web/secure/base_url checked that path is set to:
  9. Deleted possible cache + sessions files in-between all
  10. In Backend > Index Management > Tried to re-index all

  11. In WAMP > Apache modules > Enabled filter_module, header_module, rewrite_module

I have a lot Wordpress / custom projects running on localhost with alias, so WAMP itself would be fully functional and working.

  • check the apache log or php log because I think that is something related to "PHP Fatal error: Allowed memory size of 536870912 bytes exhausted", and if you are using a custom theme change to default Magento's theme.
    – Natalie
    Jun 4, 2015 at 21:24
  • Maybe the live site is using something like memcached, redis or varnish in any kind? For example session caching is set to memcached or redis but you don't have installed it? Or you have a Magento2 installation but your mysql version is too low? Something with Php version?
    – Michael
    May 28, 2016 at 21:19

4 Answers 4


Yes. I think you should go to Admin and System->Configuration->general->Web->Default Pages and select CMS Home Page to your page Hope you can solve it.


I had this same problem. This solution worked for me. Perhaps you have a similar issue going on.

In my case, there was an empty request_path in the core_url_rewrite table of the Magento database. Once I deleted the entry with the empty request_path field, my home page was accessible.


Just check if you have maintenance.flag file in your Magento root. If you have, just remove.


please check after removing your .htaccess file on magento root

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.