0

I am trying to set up some sort of automated application testing for Magento stores using the MTAF package described at these links: Guide, Docs

These guides tell you to install PHPUnit using pear, but this method is disabled as of Dec 2014.

I was finally able to get PHPUnit installed using the commands from this answer and now I can actually check my phpunit --version, which is PHPUnit 4.6.7 by Sebastian Bergmann and contributors.

The error that I am getting stuck at now is this: require_once(): Failed opening required 'SymfonyComponents/YAML/sfYaml.php'

This SO Answer says that the test framework is wanting to use the Symfony 1 version of the YAML module. I cannot find this old version anywhere, so it made me wonder if there isn't something I'm overlooking. I have already tried the Official SVN repo but it just times out.

Edit: I guess there was some issue with their servers yesterday. Today it is working and I was able to install the necessary YAML module using this command:

sudo pear install symfony/YAML

I'm not really sure if this could be considered a "question" anymore, but I feel it is a good reference for others who might want to install the test framework.

0

These are the commands that I ran to install the dependencies:

PHPUnit:

wget https://phar.phpunit.de/phpunit.phar  
chmod +x phpunit.phar  
sudo mv phpunit.phar /usr/local/bin/phpunit

Symfony YAML module:

sudo pear install symfony/YAML

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.