0

I'm running into an issue with my product search. When a customer does a search, then clicks on an item, I wind up getting a 522 error. I'm currently using varnish, magento cache, and a CDN.

If I try to open the item from the category page, it opens just fine. But if I try to open it from a search results page, then it errors out.

I get this error using either Like or Fulltext.

  • It doesn't seem to be happening on all searches, just some. Having issues with both simple and configurable products. – Eric Fox May 26 '15 at 20:21
  • Check your server error log(s). There should be something in there that can help out. – Agop May 26 '15 at 21:34
  • All I'm getting from the error log from Magento is this: ERR (3): Notice: Use of undefined constant boolean - assumed 'boolean' in /home/MYDOMAIN/public_html/app/code/core/Mage/Core/Model/Config.php on line 1348 – Eric Fox May 28 '15 at 11:53
  • Error codes in the 5xx range are all server related. If your web server (Apache/Nginx/etc.) error log doesn't have anything useful, check if the Varnish or Magento logs have any hints. Something, somewhere, is running into a server error, and there's no (good) way of finding it besides checking all possible logs. Varnish is definitely a big piece to check on, as it stands in front of your web server. – Agop May 28 '15 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.