2

For testing purposes, I had done some core changes to the following files and they worked fine.

  • /js/varien/configurable.js
  • /app/code/core/Mage/Catalog/Block/Product/View/Options/Abstract.php

So after my test, I replaced back the original with the revised files. After going through Cache Storage Management, and flushing all, I am still seeing all of my revision in place!

While looking through FileZilla at var/cache/ and it's sub-folders, flushing cache on the Back-end does NOT delete all cache in mage--0, mage--1, ... and mage--f.

I have to keep on pressing "Flush Cache Storage" to delete all. How can you delete all cache at once? And even after emptying the folders, the changes do not roll back!

What else can I do to roll back to original, even though I have both original file in place?

  • If this is a production environment cache files might not fully be deleted because visitors are requiring a page that is recreating the cache items right away. The PHP file should not be cached however. The javascript file might also be cached client side. – Sander Mangel May 26 '15 at 14:47
  • Also, flushing the cache with the button doesn't completely clear out all the subfolders in var/cache/ as there's a lot of Zend and other stuff that is permanently cached when caching is enabled. If you want a true, full cache clean, you have to manually delete the subfolders. As to the JS file, that's cached client-side cached in the browser and a good couple of CTL-F5 in the browser should do a forced reload of Javascript and CSS. – Fiasco Labs May 26 '15 at 15:01
  • @SanderMangel Thank you for the reply. This is a test site. I am the only user. When I am clearing cache, I am not refreshing or visiting the front end. So why is this happening? What can't I see the pages as they were originally? – user2774042 May 26 '15 at 15:03
  • @FiascoLabs Thank you for the reply. I did delete all cache under var/cache/. In Chrome i tried F5 and CTL-F5 a couple of times and even turned to Explorer, which I never use and it showed the revised. :-( – user2774042 May 26 '15 at 15:10
  • Test server, file/folder permissions causing Magento to create cache in /tmp? stackoverflow.com/questions/8940458/… Something's caching it, Redis, opcache? – Fiasco Labs May 26 '15 at 15:18
4

Flushing of the Magento Cache

There are a few options here, namely:

Checking the line items and submitting refresh from the Actions dropdown box
Clicking the Flush Magento Cache button, and
Clicking the Flush Storage Cache button.

and another way:

->SSH users can use the following command to flush Magento caches:

$ find ./var/cache -type f -delete

->FTP users can use the following command to cleanup Magento caches:

mrm -r ./var/cache ; mkdir ./var/cache

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.