1

After upgrading to 1.9.1.1 and running security patch SUPEE-5994 I couldn't view the system configuration page so I followed this suggestion:

http://www.tjcafferkey.me/magento/blank-system-configuration-page-magento-1-9-0-1-upgrade/

and went to /app/code/core/Mage/GoogleCheckout/etc and removed all files except config.xml

It's important to note that I do not know if removing everything from the GoogleCheckout/etc folder is the cause to this because I didn't try to load the catalog after the upgrade. I think it is more likely the upgrade caused this. also it is possible to search for the items and they show up in the search result and also you can enter to the items page just not the category pages.

Now when I am trying to view the catalog in the front-end, I am granted with this error after enabling developer mode:

Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'Mage_Wishlist_Helper_Data' does not have a method '' in /home/username/public_html/app/code/core/Mage/Core/Model/Layout.php on line 324

#0 [internal function]: mageCoreErrorHandler(2, 'call_user_func_...', '/home/username/...', 324, Array)

#1 /home/username/public_html/app/code/core/Mage/Core/Model/Layout.php(324): call_user_func_array(Array, Array)

#2 /home/username/public_html/app/code/core/Mage/Core/Model/Layout.php(214): Mage_Core_Model_Layout->_generateAction(Object(Mage_Core_Model_Layout_Element), Object(Mage_Core_Model_Layout_Element))

#3 /home/username/public_html/app/code/core/Mage/Core/Model/Layout.php(210): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))

#4 /home/username/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(344): Mage_Core_Model_Layout->generateBlocks()

#5 /home/username/public_html/app/code/core/Mage/Catalog/controllers/CategoryController.php(148): Mage_Core_Controller_Varien_Action->generateLayoutBlocks()

#6 /home/username/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Catalog_CategoryController->viewAction()

#7 /home/username/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('view')

#8 /home/username/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))

#9 /home/username/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()

#10 /home/username/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)

#11 /home/username/public_html/index.php(88): Mage::run('', 'store')

#12 {main}

Thank you for any help you could provide!

  • ok I narrowed it down to a specific extension. It works fine when When I disable it. the question now is why and how can I get it to work with the extension... magentocommerce.com/magento-connect/… – Jake May 26 '15 at 11:19
1

I ended up uninstalling the extension mentioned in my comment and re-installing the latest version of it and it fixed the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.