0

This error appears in the admin when adding shipping tracking information. The actual file/location is public_html/includes/src/Mage_Core_functions.php on line 247.

When I went to find the file, it didn't exist. I'm not good with php and am not sure if there is suppose to be a file.

History: I had the new host company move the site from the old host company. This error happened when we started selling again on the new host. I'm wondering if files are missing? I noticed in the include file a lot of files are not there under the new host compared to the old host. But I don't know when these files are created.

My host company tried to resolve the issue. No success. What they tried was upgrading php, flush cache on server, increase the limit to 600 seconds. However this did not resolve the issue with the PHP error. After they refreshed the page though, the shipping code was added successfully. But the error message came up again the second time around.

  • Looks like I spoke to soon below. Now I have a slightly different error message but similar. It says- Warning: include():Failed opening "Zend/Log.php for inclusion (include_path='public_html/app/code/local:public_html/app/code/community:public_html/app/code/core:/public_html/lib:..:/user/local/php54/pear') in public_html/lib/Varien/Autoload.php on line 93 – user3612521 May 27 '15 at 13:54
  • Maybe the library has a problem. So pls copy folder and replace it. – user33433 Nov 23 '15 at 6:09
3

It looks like you have compilation enable in your webshop just disabled from

Via Magento admin

Navigate to System > Tools > Compilation page and click on Disable button

Navigate to System > Cache Management screen and use Flush Cache button.

OR

Via SFTP, by editing the includes/config.php file

To disable compilation in Magento, edit includes/config.php. At around line 28, uncomment the first line and comment out the second:

#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');

OR

Via SSH

php -f shell/compiler.php -- disable
php -f shell/compiler.php -- clear

Check the status:

# php -f shell/compiler.php -- state
Compiler Status:          Disabled
Compilation State:        Not Compiled
Collected Files Count:    0
Compiled Scopes Count:    0

Clear the cache:

rm -rf var/cache/* var/session/*

Follow any one step And try ,,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.