7

I have overridden onepage block in my extension. However When I disable the extension from advanced system configuration My entire checkout page is not being displayed. So please provide me solution to this.

1
  • 1
    please disable your extension from app/etc/module/YourModuleNameSpace_Yourmodule.xml on file <active>false</active> – Amit Bera May 22 '15 at 5:42
3

When you disabled module from System > Configuration > Advanced > Disable Modules Output will not actually disable that module. It will, as the name suggest, disable modules output.

When you look at

abstract class Mage_Core_Block_Abstract

In

final public function toHtml()
            {
                Mage::dispatchEvent('core_block_abstract_to_html_before', array('block' => $this));
                if (Mage::getStoreConfig('advanced/modules_disable_output/' . $this->getModuleName())) {
                    return '';
                } 

// It is checking If its in disabled mode then just return blank output
    .......
    }

thats why it display blank o/p,If you want disabled module the just disabled from app>etc>modules

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.