0

After saving html to the home page (under CMS > Pages > Home), Magento 1.9.1.1 does not retain all of what was saved!

I have tried this many times. I write the code and save. When I go back to modify or add other changes to the layout, what I had saved is no longer their.

What it's even more strange it retains some html but deletes others. It has a mind of it's own.

ps. I am using the rwd theme, but have changed the theme to default also, but it behaves the same way.

Any ideas why this is happening?

  • Click 'Show/Hide Editor', then add html and save. You're likely entering <html> into Magento's WYSIWYG editor, which in laymen's terms strips your html <tags> – Tim Hallman May 20 '15 at 17:28
  • Thanks for the reply. That's what I exactly do. I key in the code in text mode and not html, and then I click on "Save Page". When I go back, to "Content" parts of the code saved earlier are no longer there, they are missing. – user2774042 May 20 '15 at 19:06
  • You probably need to add your html tags to tiny_mce then... have a look at this article alanstorm.com/magento_html5_tinymce – Tim Hallman May 20 '15 at 19:13
  • I read the article, but it didn't make any sense to me. What I did was i went to System > Content Management and set the "Enable WYSIWYG Editor" to Disabled by Default. Now when I enter the code and save, the content saved is there (it does not get deleted). I did the "Flush Cache Storage", "Flush Magento Cache", refreshed the "Layouts" (Layout building instructions). But on the cart side, front end, the page does not show any revisions. ps. cleared browser cache as well. – user2774042 May 20 '15 at 19:44
  • Perhaps you're actually editing a different page? – Tim Hallman May 20 '15 at 20:02
1

It's a 1.9.1.1 bug All of the stores that we upgraded are showing the same issue.

The ones that we didn't upgrade stay normal - no such issue.

We need to gather the list of bugs from this new update.

  • Under System -> Configuration -> Content Management, "Enable WYSIWYG Editor" choose "Disable by Default". That did it for me. It only took me 3 days to figure this out! @koala – user2774042 May 22 '15 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.