0

I am getting this error when I click on manage categories in admin and when i checked the var/report, I got this. I have already deleted my previous theme "eclipse" but i think it's still messing up with the database. Need help

enter image description here

2 Answers 2

1

Go to the database in eav_attribute table search this string ecliplsesettings/category_attribute_source_menutype u will find this in that column remove this and then clear cache and try again

0
2

It looks like you are missing a file or you had an extension that you disabled.
Does the name eclipsesettings ring a bell?
If it does and the extension is still active you should contact the developer.
If you removed the extension, you need to remove the attribute that the extension added.

Look in the table eav_attribute for a record with source_model = 'ecliplsesettings/category_attribute_source_menutype' and remove the record.
Then clear the cache and try again.

4
  • Thanks a lot, it worked. However, I found the record of my previous themes also in the database, Can I also delete them ? May 21, 2015 at 6:22
  • I don't understand what you mean by "the record of my previous themes also in the database".
    – Marius
    May 21, 2015 at 6:23
  • In the table, "eav_attribute" , there are strings of my previous themes also that i don't use now. May 21, 2015 at 6:28
  • sure, you can delete them, but make sure you backup your db before doing that. You might delete something you need.
    – Marius
    May 21, 2015 at 6:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.