5

I have a strange problem with Magento. Recently I'm not able to delete an attribute option or update the postion of an attribute option.

When I change the position i.e. from "3" to "0", it will just be the same position number after I save it.

And the same happens when I try to delete an attribute option.

The attribute has more than 200 options. Is maybe the high number of the options causing this problem?

I'm using Magento 1.9.1

Any solution would be very much appreciated.

enter image description here

  • can you change anything else in that screen? Like the attribute labels or something else? – Marius May 19 '15 at 14:57
  • 1
    That screams a max_input_vars issue. Increase the value in your php.ini and try again. – Mayers May 19 '15 at 14:59
  • @Mayers after updated max_input_vars in php.ini still getting the same error, i cannot able to delete attributes labels/options..... now my max_input_vars snag.gy/5wApou.jpg – zus Nov 16 '17 at 12:48
5

Have a look in /var/log/ and see if Magento is logging any exceptions or errors that might give you a clue as to the cause of the problem.

I once had a problem updating a category with a large amount of products where magento was throwing an error concerning input variables exceeding a configured limit. This turned out to be the max_input_variable setting in php.ini for Apache.

  • There is no error in exception.log, is any other way to find out what is the error? – zus Nov 16 '17 at 5:16
2

I increased the value of max_input_variable to 2500 and luckily it worked. Now I can finally remove or update the options.

In my .htaccess file (My Magento don't have a php.ini file so I used the .htaccess file) I added this line:

php_value max_input_vars 2500
  • Not working, after update php_value max_input_vars 2500, still values not delete – zus Nov 16 '17 at 5:22
  • after increased php_value max_input_vars 8000000 in .htaccess still not working..... – zus Nov 16 '17 at 12:53
0

The following part did the trick. 1. Open php.ini 2. Alter or Add the following lines:

; Input Vars
max_input_vars = 100000
suhosin.post.max_vars = 100000
suhosin.request.max_vars = 100000

; Memory Limit
memory_limit = 256M

; Time
max_execution_time = 3600
max_input_time = 600

; Posts
post_max_size = 512M

Restart apache and the problem is solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.