4

This is a strange problem that has occurred after installing SSL on my hosting package (not sure if linked).

I am unable to create a new user or log in with an existing user at front-end (backend is fine) when using Chrome. When submitting the form the page just reloads and all fields become blank. However when viewing customers in backend the new users can be seen.

https://www.projector-screen-material.co.uk/customer/account/login/

This problem exists on my computer and computers on completly different networks that have never accessed my page before (all in the UK). However the problem does not exist when using a VPN.

After reading other answers to similar questions I have tried all of the following with no results:

  • Delete all cache, cookies and DNS on local computer and reset browsers.
  • Deleted all cache Magento, deleted var/cache and var/session
  • Asked friends to try on different computers on different networks
  • Inserted <input type="hidden" name="form_key" value="<?php echo Mage::getSingleton('core/session')->getFormKey(); ?>" /> on all login.phtml files as decribed in this post.
  • Removed CloudFlare and purged all of its cache.

The problem has existed for around 4 days now and it is becoming a very frustrating issue. Any insight into what the problem might be would be greatly appreciated.

I can only get log in to work with firefox

  • The obvious - have you set your https url (secure url) in Magento administration? – Tim Hallman May 19 '15 at 14:46
  • Other than that, have you enabled Exception logging? What do your logs show? – Tim Hallman May 19 '15 at 14:48
  • Hi @TimHallman , so in config>web>secure I have set the url to https and Use Secure URL's set to YES. The log file shows this 2015-05-19T15:23:39+00:00 ERR (3): Notice: Undefined index: url in /home/proje499/public_html/app/code/core/Mage/Core/Model/Email/Template/Filter.php on line 288 which doesnt seem relevant to logging in problem. one interesting point is when I turn url to http and Use Secure URL's to NO I am able to log in just fine and create users at front end – Ben Lamb May 19 '15 at 15:29
  • My best guess is you have a malformed local.xml, head.xml or page.xml file. Check the <addItem> tags specifically. – Tim Hallman May 19 '15 at 15:53
  • 1
    What session verification options have you turned on? Since VPN works, I can only assume that the remote address validation fails. It's also possible, that the VPN uses a proxy and thus Magento does not talk directly to chrome. This may fix something in the request headers that fails with a direct connection. Although I can't really think of anything specific, I think you can use wild guesses after four days. – Melvyn May 20 '15 at 7:33
0

In your:

<block type="page/html_head" name="head" as="head">

check the <params> tag

<action method="addItem"><type>js</type><name>lib/ds-sleight.js</name><params/><if>lt IE 7</if></action>
| improve this answer | |
  • Hi Tim thanks for your help but sorting out the param tags didnt do anything – Ben Lamb May 19 '15 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.