3

When I try to register as well as login into customer account, I am not redirected to my customer dashboard.

In registration customer details are registered clearly in database, but I am not redirected to my dashboard. After completing my customer registration it takes me into login page instead of my dashboard why???

I have already added:getFormKey();

In XAMPP everything works fine in my web server I face this problem.

Please help me.

6
  • 1
    Sounds like your session is broken somehow. Try to tweak your session and cookie settings in the admin or in the database in the core_config_data table. – 7ochem May 17 '15 at 12:42
  • thank you sir for your idea ... i tried everything still i face the same problem @7ochem – Mild Milly May 17 '15 at 12:51
  • So the problem is that you're not redirected to dashboard after registration But can you access the dashboard by navigating there? – user3450236 May 17 '15 at 14:04
  • Try the Login Process in Mozilla Firefox Instead Of Google Chrome. I got the Same Problem In google Chrome But i logged in Mozilla Firefox Without Any issue. Just have a Try – hari haran May 22 '15 at 6:56
  • please check .browswer cookie setting – Amit Bera May 22 '15 at 7:37
1

skype: dubeychandan996 I will help you. One more things while adding form key.

<input type="hidden" name="form_key" value="<?php echo Mage::getSingleton('core/session')->getFormKey(); ?>" />

check whether you are pasting in same login.phtml that are used in frontend. sometimes in xampp also have cache issue.

For That app\code\core\Mage\Core\Model\Session\Abstract\Varien.php

/* to solve login issue */
  /*if (!$cookieParams['httponly']) {
  unset($cookieParams['httponly']);
  if (!$cookieParams['secure']) {
  unset($cookieParams['secure']);
  if (!$cookieParams['domain']) {
  unset($cookieParams['domain']);
  }
  }
  }

if (isset($cookieParams['domain'])) {
  $cookieParams['domain'] = $cookie->getDomain();*/ //I have commented these lines

or

  • Open your Magento installation directory. Locate and open index.php file.

  • Search for error_reporting(E_ALL | E_STRICT); code.

  • Comment it out like that: /*error_reporting(E_ALL | E_STRICT);*/

  • And use the following code instead:

    error_reporting(E_ALL); $_SERVER['MAGE_IS_DEVELOPER_MODE'] = true;

    Uncomment it by removing the # sign, so it looks like that:

    ini_set('display_errors', 1);

  • Save this file and upload to the server. Reload your website page to see errors.

==========alternative==================

change localhost to 127.0.0.1

paste your error if you can see.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.