I accessed the server through ssh ...

My files are in public_html so i uploaded patch in there

In ssh I ran commands to get in that folder


chmod +x PATCH_SUPEE-5994_EE_1.14.1.0_v1-2015-05-14-05-05-02.sh

and finally:


I received this output in terminal...

Can anyone help me understand this (being my first time doing this?)

Checking if patch can be applied/reverted successfully...
ERROR: Patch can't be applied/reverted successfully.

patching file app/code/core/Mage/Authorizenet/controllers/Directpost/PaymentController.php
patching file app/code/core/Mage/Core/Controller/Varien/Router/Admin.php
patching file app/code/core/Mage/Core/Controller/Varien/Router/Standard.php
patching file app/code/core/Mage/Customer/Model/Customer.php
patching file app/code/core/Mage/Dataflow/Model/Convert/Parser/Csv.php
patching file app/code/core/Mage/ImportExport/Model/Export/Adapter/Csv.php
patching file app/code/core/Mage/Install/Controller/Router/Install.php
patching file app/code/core/Mage/Install/etc/config.xml
patching file app/code/core/Mage/Sales/controllers/Recurring/ProfileController.php
patching file downloader/Maged/Model/Connect.php
patching file downloader/Maged/View.php
patching file downloader/template/connect/packages_prepare.phtml
patching file downloader/template/messages.phtml
patching file get.php
can't find file to patch at input line 347
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
|diff --git lib/PEAR/PEAR/PEAR.php lib/PEAR/PEAR/PEAR.php
|index b4633bf..e6f8edc 100644
|--- lib/PEAR/PEAR/PEAR.php
|+++ lib/PEAR/PEAR/PEAR.php
File to patch: 
Skip this patch? [y] 
Skipping patch.
42 out of 42 hunks ignored
patching file lib/PEAR/PEAR/PEAR5.php
patching file lib/Varien/Io/File.php
  • Did you check whether your install has the lib/PEAR/PEAR/PEAR.php? Maybe you removed it or excluded it from production? This answer seemed to help another person having the same issue. Commented May 15, 2015 at 17:56
  • where would i find this? in the same area as where app folder is? i certainly did not remove or edit it... maybe the theme install caused this??
    – Carlo
    Commented May 15, 2015 at 18:02
  • Yeah, lib is a subdirectory of your Magento root. Commented May 15, 2015 at 18:03
  • could i just add it?
    – Carlo
    Commented May 15, 2015 at 18:03
  • 1
    no... you were correct!!!! +++++ i was stupid enough to ad the pear folder to root instead of putting it in lib/ :( patched successsfully!
    – Carlo
    Commented May 15, 2015 at 18:19

2 Answers 2


solution (thank you fantasticrice)

lib/PEAR/ was missing so downloaded magento 1.9.1, copied the pear folder and uploaded it to lib/

patched successfully


I have exactly the same error (I reported yesterday but in an "old" question) in a fresh installation of with downloader.php, there is no PEAR folder in the original download, do you need this PEAR folder or only to fix this issue ?

Own answer : Yes, that is a difference with downloader.php you don't get /lib/PEAR but with a manually download /lib/PEAR is included. So I copied /lib/PEAR and indeed now the patch is running normally without errors.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.