3

Look at my screenshot. In System >> Configuration >> Customer Configuration >> Address templates >> PDF i removed the telephone lines.

But still the telephone numbers shows up in the Invoice PDF under Ship too / Bill to (client information).

How do i remove telephone lines completely from the PDF Print-outs in Magento 1.9?

enter image description here

  • This is the right method, and it does work. Make sure you are editing the right store view, or you don't have any module overriding the PDF generation. – Mayers May 11 '15 at 19:26
  • its strange. I configured this under Default Config. I use Fooman PDF customizer but they say also i have to use this method. I don't know what to do..? – Meez May 11 '15 at 19:54
  • I have just tried on a fresh clean install and it works first time. I would disable the Fooman module, and try again, just to rule it out. Then if it still doesn't work, it has to be another module. – Mayers May 11 '15 at 19:57
  • and you removed this line from the address template {{depend telephone}}T: {{var telephone}} ? – Meez May 11 '15 at 20:13
  • Correct, I removed exactly that from the PDF field {{depend telephone}}T: {{var telephone}}{{/depend}} – Mayers May 11 '15 at 21:13
1

Make sure you don't overwrite the default settings on store view level.

If you don't overwrite it, you have a bigger problem, somewhere in your code.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.