0

Every extension I install, regardless of what it is, says it installs fine but on my admin I either don't get access to my admin back-end with the following error or in various places I receive the following error:

Fatal error: Class 'XXX' not found in /public_html/app/Mage.php on line 547.

Where XXX is, the name of the extension is there.

  • How you installed ? Using Downloader or manually ? On both cases try to disable the installed module by making <active>false</active> under app/etc/module/PackageName_Modulename.xml – Vinoth May 11 '15 at 4:29
  • This is through the magento connect installer. – ajsonnick May 11 '15 at 4:38
  • Check your system.log files under var/log folder. It'll tell you the issue behind this. – Vinoth May 11 '15 at 5:16
1

Magento module installation always has a specific order of things that must be done for successful module install.

Only install one module at a time.

The following things must be done:

  1. If you have the compiler enabled, disable the compiler either by the backend utility or the shell script shell/compiler.php. If you've been running up to this point with it disabled, leave it that way as it has been shut off for a really good reason.

  2. Disable all caching in the cache management screen and then clear the cache either by clicking the button or manually deleting all subfolders in var/cache/

  3. Log out of the Magento backend.

  4. Install the module

  5. Log into the Magento backend, the installer scripts will run, the system will seem to hang momentarily at login.

  6. Once logged in, log back out and then back in to reload all the admin panels that might be associated with the module

  7. Clear the cache again, even though the cache is disabled, there is a lot of Zend and low level stuff that is cached despite the settings.

  8. Run Magento and test that your front end and back end are running without problems

  9. Enable all the cache items you disabled in Cache Maintenance and check that Magento is still running well with just caching turned on.

  10. ONLY AFTER proving the system is running properly, IF YOU WISH to enable the compiler a) Recompile the code base and then b) reenable the compiler

If the system will not run with the compiler enabled, disable it with the shell/compiler.php script or search elsewhere for manual file edit. Contact your module developer to see if it will run with the compiler, otherwise leave the compiler disabled, it has become rather irrelevant from 1.7.x.x forward as a speedup and usually becomes a source of problems if you're not running plain vanilla Magento.

  • Thanks! **MAJOR PROBLEM now... It appears none of the css files are working or anything, the side loads in disarray. I can install modules now, but the site theme is broken. – ajsonnick May 11 '15 at 20:05
  • If you have merge CSS and merge JS turned on, you need to turn that off and flush the CSS/JS cache. See if that brings things back. – Fiasco Labs May 11 '15 at 21:02
  • Before I checked that, was able to get most of the site back while waiting. BUT my header and lower parts of my pages are messed up. Could you take a look? I don't mind compensating. I need this back up ASAP please. thanks so much!!! – ajsonnick May 11 '15 at 21:17
0

Go to the magento root path includes/config.php and edit it commet the last two line (around line 28 like type #define)now your adminel work proper and go to compilation and run compilation process now enable the comipilation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.