0

I am having the same problem as before. I did an rsync with my prod site to make sure all files were exactly the same. It shouldn't have overwritten my local.xml because I used the exclude option. But once again I am getting the 404 not found error on any page I go to (on the dev site, which is in a subdirectory of the root) I made sure the permissions were 755 on the local.xml, and all the connection specific info is correct. What I did see is that it doesn't seem to be picking up the changes I made in the database to core_config_data to point the base url at the subdirectory. What else would cause it not to be reading the local.xml?

  • What happens when you add index.php to your url? – brentwpeterson May 8 '15 at 19:51
  • It still gives me a 404 error – Tommy May 9 '15 at 0:36
  • are you getting a Magento 404 or server 404? – David Tay May 9 '15 at 2:28
  • I'm assuming Magento 404 from my production site on the root. This site is in a subdirectory as a dev site. and all the menu links are referencing the root site. I know the local.xml thats in the dev site app/etc folder is pointing to the dev database which has the base url's set correctly. It just seems that it is not picking up the local.xml, and it is the only file in that directory so I could narrow down that it is not trying to pull from another file. – Tommy May 9 '15 at 3:34
  • you forgot to copy .htaccess file ... – user2857 May 9 '15 at 11:47
0

Enable Magento debugging features and check the magento\var\log\exception.log.

I had one of this 404 errors, spend lot of time to find why but thanks to debugging I found the culprit! turns out one of my external library files is calling a class that doesn't exist!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.