2

I have created an account on PayPal sandbox and configured the API/Integration Settings to use the appropriate username, password and signature with a Magento 1.12 EE instance on my local server. This worked fine and now, I tried removing (emptying) the credentials and updating them again with the same values and now, on the frontend I am receiving the following error.

PayPal gateway has rejected request. Security header is not valid (#10002: Security error).

As per some of the forum posts, I have cleared cache, logged out and logged backed in to Magento and I have tried the same credentials and I am receiving the above error.

Any help regarding this would be helpful.

For your reference,

  • Sandbox mode is set to Yes
  • API uses proxy is set to No
3

In my experience, 10002 is a pretty broad error, meaning that any number of things could be wrong from certificate invalidation to incorrect API credentials; I've seen this most often in conjuction with setting up Website Payments Pro. If that's the case and you're using WPP, you'll need to contact Paypal Developer Support to have them enable WPP for your sandbox account. Yes, that's a pain in the rear.

However, if you're not using WPP and you're exclusively trying to set up Express - try the following:

In Paypal, navigate to PROFILE > MY SELLING PREFERENCES > API ACCESS

Find the option that says “Accept payments from your online shops before setting up APIs” - set this to ALLOW.

For more information on Paypal error codes, check out the following guide:

https://developer.paypal.com/webapps/developer/docs/classic/api/errorcodes/

1

We ran into a similar situation when configuring Magento EE 1.13 with a slightly different resolution I wanted to share in case it helps others.

In our case, we were trying to use Production API credentials with "Sandbox Mode" set to Yes.

Getting a sandbox/developer Paypal account set up properly was proving to be a headache so we figured we'd use our live creds and just enable Sandbox/Testing the way you can with Auth.net and Shipping methods.

Apparently that wouldn't work here. We had to create sandbox API creds and use the sandbox account. Doing so resolved the error.

1

First clear to note: The error NO #10002 means you have entered Wrong API username or API password or API Signature on your Magento configuration.

Which is on: Magento Admin -> System -> Configuration -> Sales -> Payment Methods -> Paypal express checkout configuration.

So first double check these details. And clear your Magento cache and check. Is still your are having this error, then search for the solution.

Because I made this mistake.

0

Set Sandbox mode is set to NO. Just try it. It works.

0

If the above options such as confirming sandbox mode, with proper production / sandbox credentials, and clearing cache do not work. Then you can check your account settings.

Some countries have laws around further verification (Canada was my issue). Check your notifications section at the top of the menu.

I'm very used to setting up Paypal governed by American law.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.