1

I have tried this solution:

Full reindex process is already running

But that does not work, I still get the same error. The error started because the client server was full.

I have cleared space on the server and removed the lock files. I even tried rebooting the SQL server. (No help)

I cleared my var/ directory of everything.

I restarted Apache

I restarted MySQL (It's on a separate box)

I have tried via command line and Magerun

Here is some output

magerun index:reindex catalog_product_attribute


  Reindex  


Full reindex process is already running.

I have tried running the command as root as well

 php indexer.php reindexall
Full reindex process is already running.
2

You might have a correctly set up Magento environment. My guess is that your {docRoot}/var directory is writable by your server user, but not by your CLI user. Because of that Magento will switch to using /tmp/magento for var. So the CLI may be trying to write to /tmp/magento/var/locks/reindex.lock. Try su-ing to the web user and see if it works

The final solution ended being the cron running at root which was locking the lock files.

  • I ran the command as the web user. I can try changing the folder to 777? – brentwpeterson May 7 '15 at 19:22
  • Kevin, that did not help – brentwpeterson May 7 '15 at 20:07
  • chmod -R ? If that doesn't work you will need to debug Mage_Index_Model_Lock::_setLockFile() (Enterprise_Index_Model_Observer::lockFullReindexProcess() uses file locks exclusively, which is where the exception is thrown) to see where the lock file exists. – Kevin Schroeder May 8 '15 at 13:41
  • I don't think that is the issue, Magento has already given us one patch, I will keep you posted – brentwpeterson May 8 '15 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.