1

I have just install magento C.E latest version: 1.9.1.1

And after install completed, i have checked the database and find that all table for Mage_XmlConnect modules are missing.But i have check it exit till magento C.E 1.9.0.1.

Missing Table Are:

  • xmlconnect_application
  • xmlconnect_config_data
  • xmlconnect_history
  • xmlconnect_images
  • xmlconnect_notification_template
  • xmlconnect_queue

Can any one tell me.is this bug or feature on magento C.E 1.9.1.1

3

When you look at a Mage_XmlConnect.xml from app>etc

<config>
    <modules>
        <Mage_XmlConnect>
            <active>false</active>  <----- look at a this
            <codePool>core</codePool>
            <depends>
                <Mage_Checkout />
                <Mage_Paypal />
                <Mage_Usa />
                <Mage_Tax />
                <Mage_Weee />
                <Mage_Catalog />
                <Mage_CatalogSearch />
                <Mage_CatalogInventory />
                <Mage_Bundle />
                <Mage_Wishlist />
                <Mage_Rating />
                <Mage_Review />
            </depends>
        </Mage_XmlConnect>
    </modules>
</config>

By default it is disabled mode.If you enabled this then it will create table.

As per magento changelog list

Magento Resolved a potential XML External Entity Processing (XXE) exploit that might lead to a Denial of Service attack.

Magento Mobile uses the XmlConnect module to provide mobile phone storefront.Because XmlConnect is disabled by default, users who try to view your mobile storefront might see the error, “The server responded with invalid data.”

For more info Click Here

  • glad to help you @AmitBera – Keyur Shah May 7 '15 at 9:27
1

To elaborate on Keyur answer, as of Magento Community Edition 1.9.1.0 the default behaviour for Mage_XmlConnect is for it to be disabled mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.