0

I can't seem to find anything at all on the internet related to my problem which makes me think I've done something wrong along the way which has eluded me for days now.

I have a theme I downloaded called 'Ultimo' and I want to make changes to the header.phtml file without changing the core file, so obviously I would make a sub-theme/child-theme.

Inside the Ultimo 'package' it has a default theme called 'default'

To make a sub-theme I need to make a folder alongside 'default' called 'custom_theme' and then enable it within the admin panel, See below. enter image description here

I delete the cache after any changes I make. There is nothing in system > design that could override anything.

If I rename the folder 'default' to something else ONLY THEN will magento load in the desired sub-theme.

So obviously magento is skipping the sub-theme I created and going straight to default.

Please can anybody help me as I'm not sure what is making Magento behave like this.

(I made a test copy of my site from before I added the new theme and was able to add the theme, create a sub-theme and enable it no problem)

  • Have you tried putting custom_theme in the other settings as well (Layout, Skin, Templates, etc.)? – Agop May 6 '15 at 15:17
  • Yes I've tried that also, pretty much every variation – joseph drury May 6 '15 at 15:21
  • And, just to be completely clear, when you say Magento is skipping your sub-theme and going straight to default, are you referring to Ultimo's default theme (ultimo/default), or Magento's own default theme (default/default or base/default)? – Agop May 6 '15 at 15:27
  • It is skipping to Ultimo's default theme (ultimo/default). (I know this because if I edit the .phtml files within this directory then I can see changes) – joseph drury May 6 '15 at 15:30
  • Hm, that's odd. What you're doing should work fine. I even double checked the source to be sure - it should check ultimo/custom_theme, then ultimo/default, then base/default. Does the Ultimo theme come with a module that perhaps overrides Magento's default theme configuration logic somehow? I see some Ultimo settings on the left side of your screenshot. – Agop May 6 '15 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.