1

Does Magento 1.4.0.1 support PHP 5.4? Our service provider is upgrading the server's PHP soon and upgrading Magento to the most recent version is not possible with the given time frame.

  • 2
    No it is not, try to install magento and generate an invoice or the order mail? Normally there is an error thrown, because of a bad implementation of Zend_AnyModule::IForgotTheNameOfTheMethod If you fix this little "bug" it might work. – Fabian Blechschmidt Aug 9 '13 at 14:13
  • 1
    And you should update your magento IMMEDIATLY there are LOTS of security issues with this version! – Fabian Blechschmidt Aug 9 '13 at 14:14
1

PHP 5.4 is not officially supported by Magento.
See the PHP compatibility in this list of requirements. If you still want to try it, you might get into trouble. Maybe the answers in here help you.

  • Thanks. I got it running under PHP 5.4, but had to do some small fixes to get it running smoothly. At least PDF printing throws an error that needs a quick fix. Also there was a problem with duplicating a product that required a fix. – Webninja Nov 4 '13 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.