4

Good evening, I'm creating a webshop based on Magento to sell my articles in France, as I'm ready to launch the shop today I was doing some test like signup with different accounts and making purchase and I notice one big issue regarding TAX, let me explain:

Tax should be paid as:

  1. For FR customers (private) they pay taxes
  2. For FR-B2B (companies) they pay taxes

  3. For EU customers (private) they pay taxes

  4. For EU-B2B (companies) they DON'T pay taxes

  5. For outside EU customers (private) they DON'T pay taxes

  6. For outside EU-B2B (companies) they DON'T pay taxes

Now what I did is to setup two store views, one in French and one in English, both have a list of 130 products, one list translated in French, the other in English while both list have same prices.

BACKEND

  • I setup a tax rate for French
  • I setup two customer groups (Private and Company)
  • I setup to apply TAX based on billing address

THE RESULT - If I signup as a private user (without adding VAT number), Magento signup me with the Private group and bill me the VAT. - If I signup as a company user (with VAT number), Magento do the same as before

  • If I signup as a UK, DE, PT or any user or company in Europe Magento doesn't bill me the VAT
  • If I signup as a private or a company outside Europe Magento do the same, doesn't bill me the VAT and assign me the Private group.

I spent an entire week reading many tutorials, even uploading EU tax rates, but nothing to do, I really don't understand what's wrong with my setup.

Lolly

2

Although it might be that your problem is already solved, I want to add an answer.

To solve "If I signup as a UK, DE, PT or any user or company in Europe Magento doesn't bill me the VAT": You need to create one tax rate for every EU country, with the rate of your origin country. And make sure you set tax calculation to be based on "Shipping Address" at System->Configuration->Tax.

"If I signup as a private or a company outside Europe Magento do the same, doesn't bill me the VAT and assign me the Private group.": That is the correct behaviour, as countries outside the EU will not be taxed at all. If you want the prices to be the same for these customers, enable the "Cross Border Trade" option at System->Configuration->Tax.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.