1

I'm getting a bit frustrated with caching as I can't figure out where the CSS files are being cached, and I'm hoping someone can help me out.

Here's the situation.

  • I am amending the RWD theme to create a custom design
  • when I make changes to the phtml or xml files, flushing cache allows me to see the changes
  • when I change to make changes to the CSS files, I can see them being compiled by compass, and I can see my changes on the server in the newly created styles.css file
  • No matter which cache I clear, I don't see the changes on the site until an arbitrary amount of time later. Some Times 5 minutes, sometimes 30 minutes plus
  • If I browse to the CSS file location from a browser, the changes are not there, yet FTPing to the site, I see the changes.

Here are the various methods I have tried to clear cache (I have done all of these together with no success):

  • Through admin - flush cache, flush cache storage, flush CSS/JS, clear full page cache
  • Deleting contents of var/cache
  • Deleting contents of media/css and media/css_secure
  • Flushing browser cache
  • Turned off merging of CSS files in admin

I have even tried a browser on a separate PC that has never loaded the site before, and the changes are not visible.

Am I doing something silly? I hope so, but at present, I just can't complete my design as I can't test the changes I am making to the CSS in live without a massive time overhead.

Any help is greatly appreciated.

Thanks.

  • If you are definitely clearing all the caches you state then this sounds like it could be some sort of server caching. What does your server setup look like? – Andrew Kett May 5 '15 at 2:11
  • Do you use a CDN? – Kristof at Fooman May 5 '15 at 2:51
  • Hi, thanks for the replies. The server is a dedicated server running CentOS 6.6 with Plesk 12.0.18 Update #44. Sorry, unsure what else to tell you, please let me know what other information would be helpful and I'll list it. – Cobant May 5 '15 at 7:34
  • I'm not (intentionally) using any form of CDN that I am aware of? Thanks. – Cobant May 5 '15 at 7:34
  • I have also noticed that when a new css file is compiled, I cna see it instantly available in the /css directory, perfectly laid out.. but when i refresh browser cache and view the css file in a browser, the file is all mashed together with no carriage returns. After a random amount of time, refreshing this will display the correct, up to date, fully laid out version of the CSS file. Most frustrating. – Cobant May 5 '15 at 10:34
1

You're probably over this, but just for other people that have this issue with their magento system. I had this and I was really frustrated about it.

  • I've disabled all caching
  • I've changed the htaccess in case it didn cash something.
  • I even change magento core functions and backend configuration to make sure it isn't doing anything to the system.
  • I also get back my changing track, in case I've done something to the system while changing.
  • I also Look up the database but the database was working very well.

Nothing worked then, It turned out that the problem is the server, that said "...Your account as requiring an inordinate amount of server resources..." After upgrading this issue was gone.

enter image description here

0

Retrospectively looking at this, this issue was the situation which I inherited. I came on board with an e-commerce operation to assist with no direct line of communication to the previous administrator who was unavailable to contact.

A whole host of 'performance-enhancing' extensions had already been deployed, and I believe these were the culprits here. I resolved this issue by moving to a to a new vanilla magento installation and migrated across data, theme and key extensions to be in complete control of the environment. The issue then disappeared.

Whilst this is a very specific solution to a specific situation, I hope that some of the answers or comments are useful to anyone landing here..

If you are experiencing this issue it is likely to be to do with some form of CDN or some form of caching from within an extension you have previously installed. Or alternatively the helpful potential solution 'key' posted may assist you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.