0

I'm having a strange issue with compass compilation, it seems that even though i have overridden rwd scss files such as /mixin/_typeography.scss, the old copy is still being used for compilation by the @include h2 reference in _product-list.scss, but (correctly) the new copy is being used by _common.scss.

If i go to the mixin folder of the rwd theme and rename _typeography.scss its all fine.

I get the same results with a compass watch batch file or using grunt contrib-watch-sass.

I've tried deleting the sass-cache - no difference.

Config.rb is as follows:

require 'susy'

http_path = "/skin/frontend/tpt_rwd/default/"
add_import_path "../../../rwd/default/scss"

css_dir = "../css"
sass_dir = "../scss"
images_dir = "../images"
javascripts_dir = "../js"
fonts_dir = "../fonts"

relative_assets = true
output_style = :compact
environment = :development

and grunt config is:

options: {
      http_path: 'skin/frontend/tpt_rwd/default/',
      cssDir: 'skin/frontend/tpt_rwd/default/css/',
      sassDir: 'skin/frontend/tpt_rwd/default/scss/',
      imagesPath: 'skin/frontend/tpt_rwd/default/images/',
      javascriptsDir: 'skin/frontend/tpt_rwd/default/js/',
      fontsDir: 'skin/frontend/tpt_rwd/default/fonts/',
      importPath: 'skin/frontend/rwd/default/scss/',
      relativeAssets: true,
      outputStyle: 'compact',
      environment: 'development'
}

Obviously this is really holding me up, and really causing me to scratch my head! i know i could just copy all the sass to my theme and remove the import in config, but it seems silly to have to. What am missing\doing wrong?

0

This sounds like you may have some caching issues. Either delete the hidden .sass-cache folder manually or run compass clean from the command line.

Do you use compass watch or do you compile manually?

/edit: sorry, I just re-read your post and saw the compass / grunt edit. If you delete the cache and the problem persists, surely you must have some other problems somewhere. Are there any other hidden files in the scss folder?

  • I just tried a manual clean, and it still gives the same output. nothing extra showing in the folders, and even svn commit shows no 'new\extra' files – Dean May 4 '15 at 15:49
  • Also = i'm trying with both grunt and std compass watch, both show the same behavior. two things that may be relevant, i'm on windows and i use modman so the folders are symbolic links – Dean May 4 '15 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.