0

i setup Cron Job for Magento 1.9.1.0 its sending emails but sending 1st email again and again. I check table "core_email_queue", i think after Sending, Email should remove form this Queue/table but its still exist in the table & other emails are on pending.

6
  • What are you cron setting for core_email_queue_clean_up, by default the setting for clean up is once per day every midnight. But any email in Core_email_queue table that has the "processed_at" field filled should not be sent again in the next queue. It is odd that's its only sending the 1st email only though, are you using the default magento 1.9 for sending emails and are all the other emails in the queue too? If so please provide the following code. From Mage_Core_Model_Email_Template the methods send() and sendTransactional() and from Mage_Core_Model_Email_Queue; send() and const msg limit May 4, 2015 at 10:19
  • I am using default magento 1.9 for sending emails additionally i m using 'AOE Scheduler. When i update processes_at field in database now its sending 2nd email again n again. its not updating processed_at field. and corn setting for core_email_queue_clean_up is 0 0 * * *. can u please tell me form which files i can take those code? May 4, 2015 at 11:11
  • You can find them root/app/code/mage/core/model/email/template.php and root/app/code/mage/core/model/email/queue.php, although i dont there is going to be anything wrong with them but just to make sure. Is this a fresh install or did you upgrade your magento from an older version May 4, 2015 at 14:08
  • There is no Mage folder in core, i search template.php there is a lot of files name template and queue.php and this is fresh install, its magento 1.9.1.0. i already fixed this problem with "ASchroder_SMTPPro-2.0.6", but again i want to know what is the problem.. May 5, 2015 at 6:43
  • The Mage folder is in code not core but anyways at least you got it working not sure if the extension you used actually fixes it or maybe bypasses the queues but it seems like there was a problem with queue collection somehow as your emails were not getting processed_at data and it was only sending 1 email at time per cron run, by default it should not be doing this it should send a bunch at a time. Don't know what could have caused this problem to happen though. May 5, 2015 at 7:36

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.