2

I have a theme that I bought and downloaded and followed the instructions to create a sub-theme.

If I edit the core theme files I'm able to achieve what I want but if I replicate it in the child theme, nothing happens.

I'm not sure what I'm doing wrong, here is my structure.

C:\wamp\www\website\app\design\frontend\ultimo

and inside there reside "default" and "custom_theme"

magneto

The file I'm trying to change is header.phtml which resides in.

C:\wamp\www\website\app\design\frontend\ultimo\custom_theme\template\page\html
3

Did you disable or flush the cache?

According to you said, 'nothing happened', can you try:

input the 'default' in default field, and input the 'custom_theme' in template,skin and layout field.

Good luck.

==================Update following content=====================

Hi, I just download whole new free theme bluescale and make a sub theme, and edit the header.phtml file and it works.

edit header.phtml set the design config magic

Since you did not provide more detail about your problems, such as 'nothing happend' or your theme file structure, so I did it whole example for you.

And Magento's structure is based on a fall-back hierarchy, so I GUESS there are something you need check:

  1. Does 'ultimo' folder has folder named 'default' to supporting your theme?

=================Latest Update======================

I just test the custom template on Ultimo theme(Ultimo_v1.3.2), it still working.

Ultimo Theme

All I can say is your configurations for the theme setting seems all good so far.

So I am going to Keep guessing:

  1. did you try remove var folder in the root path ?

  2. did you try check the file permission ?

  3. did you try a clean Magento and install the new custom sub theme. If new clean Magento working with custom sub theme, you may want to disable the extensions one by one to find out which extension causes theme problem.

if all of above nothing work, change the WAMP to XAMPP or keep googling.

  • I always flush the cache after any changes. In the user guide for the theme I bought it tells me to make my sub-theme the default as it will fallback to default for any missing files – joseph drury May 4 '15 at 11:04
  • @josephdrury I just updated the solution, hope it helps you this time. – Wei Jing May 5 '15 at 3:51
  • Thanks for the images! My file structure is EXACTLY like the one you made in the example. And yes, the 'ultimo' folder has a folder inside called 'default'. The problem is, Magento is automatically ignoring my 'custom_theme' and reverting straight to the default theme inside the ultimo package. For whatever reason after a restart of my pc It was working for a short while, but then after a while it went back to using the default theme again. – joseph drury May 6 '15 at 10:56
  • Here is a screenshot of what I have. imgur.com/bt6ZHrg Inside of header.phtml I have a "Hello world" like yours, but it isn't coming up. – joseph drury May 6 '15 at 11:01
  • @josephdrury I have update the answer. if none of these working, I am out of solutions. basically the new clean Magento should be the best chance to find out where is the problem. and there is many way to debugging the Magento. Maybe this problem has been beyond the Magento theme settings problem. Good Luck, you really need that. – Wei Jing May 7 '15 at 0:00
1

As I suspected, I enabled something I shouldn't of somewhere.

In this case it was in CMS > Pages

I activated the default theme for the package I was using on the home page. (didn't think to look here because I thought the header wasn't classed as a page)

Days wasted because of my own carelessness.

solution

0

You have put custom_theme in the default section of your theme. This makes custom_theme as your default theme. So the real default theme is now in nowhere. Magento will avoid default theme in the callback mechanism as you have specified custom_theme as your default theme.

So the solution is, you have to put default in default section and put custom_theme in all other section. This way custom_theme become your current theme directory and then default as your sub-theme (aka default theme).

  • but doesn't magento have a fallback mechanism? It goes Custom_theme > default theme > base theme – joseph drury May 4 '15 at 10:30
  • as per above congiguration, magento follows custom_theme > base. if u want to have the above fallback mechanism, u want to set custom_theme as all other theme configuration except default field and put default in default field (or keep it as empty) – Rajeev K Tomy May 4 '15 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.