We have a problem with our create a account page. Even when all field are filled in we still get a message: "****" is a required field. The page where we get this error is:


Does anyone know a solution or a way to remove this requirement.

3 Answers 3


I have checked it and it's saying "your room" is a required. whereas I can't see this field. You can do two things:

  1. You can delete this required customer attribute from database. For removing any custom attributes run below code by adding some where in your loading templates file

    $setup = new Mage_Eav_Model_Entity_Setup('core_setup');
    $setup->removeAttribute('customer', 'customcode');`

    Note: replace customcode with attribute code of "your room" Once run, please remove above code.

  2. Or, If you don't want to remove this customer attribute then post a dummy or null value using hidden type field with this attribute from customer registration template.


The Name and Address Options panel is useful if you want to add fields to the pages on the frontend where name and address options appear (e.g. registration form, customer accounts, checkout). You can add a field for a prefix (e.g. Mr., Mrs., etc.), you can add a field for middle name initials, you can also add a field for a suffix (e.g. Jr., Sr.,), for the date of birth and gender of the customer.


Remove class="required" code from .phtml file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.