1

On our web site we have thousands of products.but the problem is product page under some category are blank.I am unable to see any error. I try all the method to see error but failed.

Please help me to see the error message on product detail page. Here is the page.html click on any product under this category you will see the blank page.Now go to this page here click on any product it will work fine.

  • check number of products of particular category which shows no product in frontend from admin manage category section. – monojit banik Aug 8 '13 at 7:14
  • increase max_input_vars in php.ini or htaccess and check it. – monojit banik Aug 8 '13 at 7:17
  • do u check the error log ? – monojit banik Aug 10 '13 at 11:00
  • Yes in system log I am only getting this 2013-08-07T11:00:16+00:00 ERR (3): Notice: Trying to get property of non-object in /home/bthings/public_html/app/code/core/Mage/Adminhtml/Model/Config/Data.php on line 135 – user2344179 Aug 10 '13 at 11:02
  • it is strange product under all the category is working fine except only ceillinh-lights and its subcategory. – user2344179 Aug 10 '13 at 11:03
2

To display errors go to your index.php and make sure both Mage::setIsDeveloperMode(true); and ini_set('display_errors', 1); are active. As this is a live webshop I suggest wrapping it in an IF statement that checks for your IP or something along that line. This will output errors directly to your screen.

I did a quick Google Search and found this thread and this post that are about the specific error you mentioned showing up in your error log.

  • i did that but unable to see any error on my screen. – user2344179 Aug 10 '13 at 11:54
  • very strange, it might be something in your server configuration that is preventing you from outputting the errors. Did the 2 links help you in any way resolving the issue? – Sander Mangel Aug 10 '13 at 11:56
  • no I have updated the code as asked in the given thread.When i move the product of ceilling category to any other category it works fine. – user2344179 Aug 10 '13 at 12:03
  • You might need to debug by printing out what object it's trying to call there when the variable is no object. This way you can backtrace where the issue origionates – Sander Mangel Aug 10 '13 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.