3

I am using Magento CE 1.9 and trying to install security patch SUPEE-1533 but it's giving me this error:

Checking if patch can be applied/reverted successfully...

ERROR: Patch can't be applied/reverted successfully.

patching file app/code/core/Mage/Adminhtml/Block/Dashboard/Graph.php
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file app/code/core/Mage/Adminhtml/Block/Dashboard/Graph.php.rej
patching file app/code/core/Mage/Adminhtml/controllers/DashboardController.php
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file app/code/core/Mage/Adminhtml/controllers/DashboardController.php.rej
  • i was successfull installing SUPEE-5344 patch following the same process. – kanand304 Apr 24 '15 at 7:33
  • Out of curiosity, have you modified any of the Magento core files being patched? The messages are indicating that the patch didn't succeed (you already guessed that) and it's saving the details of the rejections in each of those .rej files it warns you about above... What version of Magento are you patching and what .sh file did you use to patch it? – Bryan 'BJ' Hoffpauir Jr. Apr 24 '15 at 7:40
  • I have used this patch "PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh" file which is for EE i think but i am using CE and it always gives me patch for EE and not CE.Can you help me resolve this? – kanand304 Apr 24 '15 at 7:52
  • I noticed the same thing when I downloaded the patch for our CE installations. The file is named PATCH_SUPEE-1533_EE, so don't worry about that part. What version of Magento were you running pre-patch? And are you using a source control repository like git or mercurial or svn in case you need to back out your changes? – Bryan 'BJ' Hoffpauir Jr. Apr 24 '15 at 7:56
  • This sounds like the system doesn't have write access to the files. Or the files have been modified by hand. If the auto patching doesn't work. You can review the patch file contents and patch manually. – Barry Carlyon Apr 24 '15 at 11:17
7

The patch 1533 is already applied in Magento CE 1.9.1. However, 5344 is not, and should still be manually applied.

3

You can find the all patches of magento to install without SSH https://www.milople.com/blogs/ecommerce/applying-magento-security-patch.html

1

I also encountered the same issue. The messages imply that the patch is already applied or maybe it's irrelevant for the community edition. In any case, it is possible to revert the patch and reinstall it to make sure it is applied. I tried this on my server. Don't know if it is really installed right now, but I'm pretty sure that it didn't break anything.

To remove the patch

sh PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh -R

To reinstall it

sh PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh

Hope this helps.

0

Here is some steps to Run security patche files in magento

Steps To Run Security Patche File in magento. First download security error patche file from magento community . Download files move it into root folder in magento. Create a php file in root directory of magento for run patche files. Rename Security patches files accorfing to you.

Final Step Open Php file and add these function in php

<?php
print("<PRE>");
passthru("bash patch-1.sh");
print("</PRE>");
//patch-1.sh define the name of download security patch file name .
?>
  • thanks for your answer. I did exactly like you suggested above i.e. <?php print("<PRE>"); passthru("bash PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh"); print("</PRE>"); ?> But stil giving me the same error. Can u please tell me if i have missed something – kanand304 Apr 24 '15 at 8:05
  • can you rename the download patch file – Aman Dhiman Apr 27 '15 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.