I'm currently experiencing some urgent problems with my Magento website.

I have upgraded my website from to and now it seems like the upgrade script (database) do not run entirely.

Table 'website.core_email_queue' doesn't exist' in /home/magento/lib/Zend/Db/Statement/Pdo.php:228

Some settings are also missing in the core_config_data tables... Is it possible to rerun the upgrade scripts manually because currently I can't find where...

Some people suggest to modify the version in core_ressources but I don't think it's the best solution. I have triend to reinstall Mage_Core_Modules and Mage_Core_Adminhtml from the downloader but it doesn't seem to work.

I also have tried to redownload the core files of Magento and override core file in my setup, but it doesn't work at all. I can't get the missing tables created.

Thanks !

  • 1
    I would guess that the re-downloaded files won't make any difference, if you're pointing at the database, due to the reference in core_resource. it reads this version number first before looking for files to apply patches for. if it's already higher, it wont install the patches again. Apr 21, 2015 at 14:24
  • Looks like you have a module, which create a core_email_queue table. Try to reinstall it.
    – mr4eshir
    Apr 21, 2015 at 14:27

3 Answers 3


You can solved the problem by downgrading the version number in the table core_resource, as already written.

Alternatively, you can use tools like n98-magerun to trigger all install scripts

n98-magerun.phar sys:setup:run 

It has always solved my problems.


I have solved my problem by downgrading the version number in the table core_resource.

Don't know if it's the best way to proceed, but it works.


I was having a similar problem with the sales_bestsellers_aggregated_yearly table after upgrade from 1.9.1 to 1.9.3. It was on my beta server and I realized that some upgrade scripts didn't run because I forgot to reset file permissions after pulling the new files down from github.

sudo chown -R www-data:www-data /path/to/magento/. 

did the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.