4

When I 'duplicate' one of my simple product, it takes 8 ~ 11 seconds to complete duplicate process. I create new clean store on my same server, and the new store take less than 2 seconds to complete duplicate product so I don't think it's server problem

My store have 90,000 sku products. is this the reason to take 8 ~ 11 seconds to duplicate? If so, is there any method to reduce time for duplicate process much?

enter image description here

2

A lot of time can be taken by re-indexing, especially with a large catalog.

Disable indexing, before you duplicate. Does that reduce time?

It can help to complete all the duplication you need done, then, re-enable indexing or first do manual indexing, then re-enable, after all duplication is completed.

If you are only duplicating one product at a time, every now and then, disabling indexing is not really helpful, as you are just shifting the time it takes to complete the process for one item, and it can in fact make the process take longer, as it requires additional steps. so not really all that useful. That said, the illusion that it takes quicker to do something, is sometimes all that is needed. Seen that happen way to often ;)

You can also try and determine where the delay is. Could be a third party module, or some external resource. (some external call made to another system, for whatever reason...)

Install the great Profiler tool called AOE_Profiler, and use it to determine the bottleneck.

NewRelic is also a great tool to use, and can show where your bottleneck is. An example of how to use newrelic to find latency is here: http://www.proxiblue.com.au/blog/new-relic/

| improve this answer | |
  • Does 'disable index' mean 'Manual update' index mode? I make all index as 'manual update' and then duplicate take 5 seconds now! Much better Thank you! currently all of my index say 'Reindex Require' with red color and I'm running the store without reindex since I need duplicate many items. Is there any problem to run store with all index say 'Reindex Require'? – Moon Apr 21 '15 at 14:15
  • 1
    @JohnG. Yes, manual update is 'disabled' mode, in the sense that magento will not re-index automatically. Yes, you will find inconsistencies in data retrieval if you continue. Too much to explain, just google about magento indexing, and what it is used for. I suggest you re-enabled each index at a time, and determine which is the cause for the slowness. You can at least then have (most) enabled – ProxiBlue Apr 21 '15 at 14:25
  • That's good idea. I will test each index and find the reason Thank you very much! Have a great week! :) – Moon Apr 21 '15 at 14:28
  • 1
    @JohnG.Ok, so considering the end-result, The only issue you'll have is that the the seo friendly urls for your products will become dated. This is the urls where you have /some-product-name.html. you may end up with urls to products that look like /catalog/product/view/id/1234 - I suggest you have a daily job of rebuilding the url rewrites index, and I suggest you do this outside magento eco-sytem, using the shell indexer - this means you can setup a cron via your hosting that will run the command 'php <magento root>/shell/indexer.php --reindex catalog_url (and catalogsearch_fulltext) – ProxiBlue Apr 22 '15 at 2:09
  • 1
    Further, you may be interested in this solution: ecomdev.org/2011/10/08/ecomdev-breaks-magento-speed-limits.html - not used it myself, but well worth considering, to keep your SEO urls up to date – ProxiBlue Apr 22 '15 at 2:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.