0

When I am in Admin and go to Customers and then to Manage Customers it produces a list of the customers, but if I try and edit any of them, either by clicking on the customer or clicking on Edit next to a customer it just takes me to a blank page.

I've looked at every answer I could find and tried the solution, but nothing fixes it.

I edited my public_html/php.ini file and increased the memory_limit from 128m to 512m. I edited my .htaccess file and added this line: suPHP_ConfigPath /home/CUSTOMERID/public_html (changing the CUSTOMERID, to my Hosting CustomerId.

I tried a suggestion went into

app/code/core/Mage/Adminhtml/Block/Widget/grid.php and changed:

public function getRowUrl($item)
{
    $res = parent::getRowUrl($item);
    return ($res ? $res : '#');
}

}

to

public function getRowUrl($item) 
{ 
return $this->getUrl(’*/*/edit’, array(’id’ => $item->getId())); 
}

Which totally crashed my ADMIN until I reinstalled the original Grid.php file.

I looked in index.php file for this line to see about error reporting: ini_set('display_errors',1);

and found that this was already in:

if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
Mage::setIsDeveloperMode(true);
}

#ini_set('display_errors', 1);

I looked in error_log and didn't find any errors concerning Admin.

2 Answers 2

1

This means your customer.xml file is edited and it had some bad codes inside it. Errors like this can be easily traced out, if you put your site in development mode. For this you need to try this .

In short, you need to edit index.php in your root directory and

//if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
Mage::setIsDeveloperMode(true);
//}

ini_set('display_errors', 1);

do the above mentioned changes. You also need to activate log files via admin side. For this go to System > Configuration > Developer > log.

This way you will get an idea on what actually gone wrong in customer.xml file. Hope that will help you in future. Thanks

0

Just as I was posting this and looking back at all of the solutions I tried I came across someone mentioning that they reinstalled the customer.xml file in app/design/adminhtml/default/default/layout/

So I reinstalled the customer.hml file from the original Magento files, and boom, that fixed it. Don't know what was wrong or why, or if I screwed anything else up, but it's working right now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.