1

I'm new to Magento (using 1.6.1) and I'm getting very frustrated with it!

Whenever I type my virtual host url into the browser "http://website" it goes straight to the live site.

I've googled the problem over and over to no avail unfortunately.

I've tried:

  • changing the secure and unsecure paths in core_config to point to http://website
  • clearing out everything from var/cache
  • checking local.xml to make sure it was accessing the correct DB
  • checking .htaccess to make sure there wasn't a redirect in there.

I've looked at similar or the same questions on here and I can't seem to find my solution!

Please let me know if I have missed any key information out.

Any help would be greatly appreciated!

  • 2 questions for you: 1) Is your virtual host local and does it have the same domain as the live host? -- Be sure your local host file has the local IP for the domain, and/or change the domain altogether. 2) Are you only changing the un/secure domains in the db and not in the admin config? -- Be sure to check the secure/unsecure settings in System > Configuration > General > Web, or it will continually overwrite your changes in the db. – gtr1971 Apr 15 '15 at 13:31
  • 2
    Clear everything from var/session as well because base_urls are stored in user sessions. Don't forget to clear cookies, just to be safe! – Ryan Street Apr 15 '15 at 13:57
  • turns out changing it to "website.local" worked! – joseph drury Apr 17 '15 at 14:31
1

I got the same problem. I solved it after setting permissions to folders.I set permission using below command and it worked.In my case root is the admin user. Please update command accordingly.

sudo chown -R root:root .
sudo find . -type f -exec chmod 777 {} \; && sudo find . -type d -exec chmod 777 {} \;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.