2

I am trying to install Magento and I am getting this error:

The URL "https://something.com/" is not accessible.
Error parsing body - doesn't seem to be a chunked message

Weird because I am on that page...

I am getting this error when I am on the page: "Configuration".

Here is the options I selected:

  • Enable Charts
  • Use Web Server (Apache) Rewrites
  • Use Secure URLs (SSL)
  • Run admin interface with SSL

Here are the options I did not select:

  • Skip Base URL Validation Before the Next Step
  • Skip Secure URL validation before next step

I have a Ubuntu server with NGiNX server. I am using the most recent version of Magento community.

What is causing the problem and how can I solve it?

  • 1
    Path validation is not possible with Nginx, try selecting the Skip URL Validations when installing, that should resolve the issue. – Daniel Kenney Aug 4 '13 at 4:57
  • I tried and it did not work. – jnbdz Aug 4 '13 at 5:14
3

I can't tell you what causes the problem you have because it seems to be quite localised. But here is the way to debug it.

The first line of your message leads us to Mage_Install_Model_Installer_Config::_checkUrl method. It sends request which is handled by Mage_Install_WizardController class.

Then the response body is checked in Zend_Http_Response::getBody if header contains transfer-encoding string and if it is chunked. If so Zend_Http_Response::decodeChunkedBody is called and if

! preg_match("/^([\da-fA-F]+)[^\r\n]*\r\n/sm", $body, $m)

The second line of your error is thrown.

So the first thing is to find out why do you have transfer-encoding=chunked and the second is why Mage_Install_Model_Installer_Config::_checkUrl is called at all as you said you disabled base url checks(s!).

UPDATE

Of course the easiest workaround would be to comment out the contents of Mage_Install_Model_Installer_Config::_checkUrl except return statement. Then you will be able to see if there will be more problems.

  • I tried to modify my NGiNX configs to see if the problem was from there... Nothing... I did some research and I haven't found anything. – jnbdz Aug 4 '13 at 15:50
  • I also did Magento test... It says everything is in place. So I am not missing anything. I really don't know anymore. – jnbdz Aug 4 '13 at 15:53
  • I modify the memory_limit and max_execution_time... But to no change. – jnbdz Aug 4 '13 at 19:50
  • Please see my update. – user487772 Aug 4 '13 at 20:03
  • Sounds like a missing module like mbstrings or something? – philwinkle Aug 5 '13 at 22:02
5

This happens because we run both Apache and NginX on our servers to give you maximum performance. Apache handles the PHP code while NginX is used to serve static content such as images and javascript faster than Apache can.

To install Magento enable "Skip Base URL Validation Before the Next Step" in the installation and your install should proceed without the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.