0

I just updated my zendserver. then when I tried to access /admin on my magento local I get the following error Value '29,990000' has to be numeric

I tried to replace

$price = sprintf("%f", $price);

with

$price = (float) $price; 

in app/code/core/Mage/Directory/Model/Currency.php but the above didn't work at all.

Then I tried to change "precision = 14" to "precision = 8" in my php.ini but still I could find a solution on this issue

  • In which file & line does the error occur, and where does the number come from? – simonthesorcerer Apr 10 '15 at 16:34
  • Check your locale settings (system wide and in php.ini), looks like the settings for number format are wrong for Magento – Fabian Schmengler Sep 1 '15 at 10:16
-1

I've resolved this by downgrading my PHP from PHP 5.5 to 5.3

  • That's not a satisfying solution. Don't run PHP 5.3 in production anymore, its lifetime has ended over a year ago (i.e. no security updates) – Fabian Schmengler Sep 1 '15 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.