1

All immages in frontend were replaced with placeholder image after running the scritp on this post:

Mass change product URL keys to match product names

No cache is active

Any idea why and how to solve this issue?

  • Have you tried clearing the image cache? In System -> Cache Management -> Flush Catalog Images Cache? Probably the image cache is still active. – Hans Blaauw Apr 8 '15 at 11:42
  • Yes, I flushed all cache, disabled chache, and refresh. The issue started after running the script. Before running the script I increased the following values php.ini memory_limit = 8192M; my.conf max_allowed_packet = 8M query_cache_size = 128M . but i don't think is related to that. I also installed github.com/Vinai/VinaiKopp_StoreUrlRewrites – user2478262 Apr 8 '15 at 12:16
  • The script you mentioned doesn't do anything with images, so I doubt if that's the cause. But maybe decrease the limits you changed a bit, you don't need a memory limit of 8 gig. – Hans Blaauw Apr 8 '15 at 12:32
  • Are you using flat tables? Are you able to see images in backend? If so, you need do reindex(since flat tables are not up to date) – fonda Apr 8 '15 at 13:11
  • I rolled back values in php.ini and my.conf. Unfortunately didn't change situation. I have also another Magento installation on same server, but its product images are working fine. Is there a way to debug and see why Magento is loading placeholder image? – user2478262 Apr 8 '15 at 13:15
1

SOLVED

The issue was related to memory_limit value in Plesk 12 vhost php setting. Value was set to memory_limit = 1G , but looks like magento for some reason, don't properly read value "1G" from the server configuration.

Once i set memory_limit = 1024M it started working again.

  • You should mark your own answer as accepted so that the question shows up as solved. – fantasticrice Apr 8 '15 at 18:06
  • 1
    I tried but it say i must wait till tomorrow – user2478262 Apr 9 '15 at 8:30
  • Same problem same solution, thank you VERY much for taking the time to post it! – Wren Dec 10 '15 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.