5

There has been some write-up on StackExchange yet. but i cannot seem to fix it. My magento transactional e-mail are not sending. While when i manually press "sent email" in the back-end it sends my emails without any problem.

Here some specific information about this installation

  • Running Magento 1.9.1.0
  • Running Mandrill Ebizmarts plugin
  • Running Aoe_Scheduler and heartbeat is running
  • Checked Exception.log no errors
  • Checked System.log no errors
  • Checked Mandrill.log and the manual emails are logged. further no errors.
  • I have not disabled email communications in config.
  • All settings double checked.

Really have no clue anymore.

Edit

Ok what i have noticed, the cron stays empty when creating orders. still all logs dont show any errors. while if there are any errors it will show them. So the CronJob stays empty!

  • This has been asked a number of times but the short answer is as of Magento 1.9.1.0 you need to run the cron to send transactional emails as they queue. – Eirik Apr 7 '15 at 20:21
  • If you read the post @erik, you see i installed the AOE_Scheduler to be sure the cron runs and tis running perfectly – Kay Int Veen Apr 8 '15 at 4:48
  • Check Spam mails, All mails must be going in spam. You have to override the email templates of Magento to avoid same. – Akshay Taru Jun 11 '15 at 3:42
1

Have you checked app/code/local/Mage for overrides? Rename the whole folder temporarily to check if this helps. Also some module could be interfering. What happens when you disable mandrill, does it work then? If necessary keep disabling until you hit default settings.. You might figure out what customization is causing it.

  • Assuming you're on a staging server by the way:) – willem wigman Apr 10 '15 at 6:47
  • Jup no overrides. and all other emails are sending just fine ;-) – Kay Int Veen Apr 10 '15 at 10:07
  • Yes, just because all other emails are sending (I didn't miss that in your post) I would guess there is some pre-1.9.1 code active in an override since the Cron-queue for emails didn't exist yet. Did you check with local modules disabled? If you go to core-code only are the emails sending? – willem wigman Apr 10 '15 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.