4

I'm not quite sure what could be causing this issue, we have absolutely NO extensions or modifications. This happens on a fresh install with one product made being the only change.

It doesn't matter if we're in the the RWD theme or the modern theme. When clicking "place order" the order submits in the backend of Magento, the button disappears for a second and says "submitting order" and then the Place Order button shows back up. No forwarding to the success page, this causes people to just click "place order" over and over, and it submits a new order every time. No theme will take us to the success page.

1
  • Enabling mbstring is very helpful. Thanks very much.
    – user32109
    Commented Oct 14, 2015 at 15:22

1 Answer 1

5

Solved! Magento was lazy with their changelog and lazy with not updating their magento-check.php file.

1.9.1.0 requires that your server has php-mbscript (mbstring) enabled in Apache.

Go into WHM or whatever your server software is and enable it and your checkout will work.

Would've saved me a lot of headaches if they just came out and said this.

2
  • Can you elaborate how to enable php-mbstring package after installed on your OS? I did mine on CentOS using yum install php-mbstring and restarted apache httpd but problem still not resolved. my case is orders not been added and i am on the same version of Magento.
    – d4v1dv00
    Commented May 6, 2015 at 14:27
  • I had the same issue and found file permissions were incorrect on /lib/Zend/Mail/Transport/Sendmail.php I set file permissions to 644 and everything clicked back on (as well as emailing out a backlog of order notifications) Hope this helps someone else.
    – ninedozen
    Commented Jan 19, 2021 at 20:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.