2

I am using CE 1.7.0.2 all indexes stuck at processing since 24 hours. When try to do indexing manually throw an error:

xxx Index process is working now. Please try run this process later

As per https://stackoverflow.com/questions/14127430/magento-indexes-issue-cant-reindex I always use SSH to do indexing. I deleted all files under \var\locks, DIR permission is 777 But when tried indexing one by one then throws same error and locks files regenerate again.

Please tell how to fix this?

1

3 Answers 3

1

I solved this problem by executing the following steps:

1. Recreate each index individually executing shell commands:

php shell/indexer.php -reindex catalog_product_attribute

php shell/indexer.php -reindex catalogsearch_fulltext

php shell/indexer.php -reindex catalog_category_flat

php shell/indexer.php -reindex cataloginventory_stock

php shell/indexer.php -reindex catalog_category_product

php shell/indexer.php -reindex catalog_product_price

php shell/indexer.php -reindex tag_summary

php shell/indexer.php -reindex catalog_url

2. Clear all files inside of var/locks/ directory

3. Apply 777 permission to var/locks/

1

I have solved this issue at my end successfully :)

  1. First you delete locks folder under var directory: var/locks
  2. make sure 777 permission is var/locks and all files under locks directory.
  3. Take a backup of your database & delete catalog_product_flat_1, catalog_product_flat_2 or if there is another one.
  4. execute following code:
php indexer.php --reindex catalogsearch_fulltext

This will reindex your Catalog Search Index or if you want to update all of the indexes run:

php indexer.php reindexall
-1

Do following steps to fix this error.

  1. Clear your database logs, you can find mysql query in below link https://docs.nexcess.net/article/how-to-perform-magento-database-maintenance.html

  2. Take a backup of your database & delete catalog_product_flat_1, catalog_product_flat_2 or if there is another one with name catalog_product_flat_2, You need this step if you are using flat catalog options enabled.

  3. Run one by one indexer through SSH commands

    php ./shell/indexer.php -reindex catalog_product_attribute
    php ./shell/indexer.php -reindex catalogsearch_fulltext
    php ./shell/indexer.php -reindex catalog_category_flat
    php ./shell/indexer.php -reindex cataloginventory_stock
    php ./shell/indexer.php -reindex catalog_category_product
    php ./shell/indexer.php -reindex catalog_product_price
    php ./shell/indexer.php -reindex tag_summary
    php ./shell/indexer.php -reindex catalog_url
7
  • Its seems risky to me. As I already deleted all log from database, but still all indexes are in processing status. If I delete catalog_product_flat_1 and even after that if re-indexing (using SSH) throw an error then it will be trouble. Will you tell how I can find, why indexing always in processing status?
    – Sandesh
    Apr 1, 2015 at 13:43
  • send me cPanel or FTP/magentoadmin/phpmyadmin access to look into your issue. Skype: amalik62 Apr 1, 2015 at 14:09
  • Also please provide me more information, what all the indexes are in processing or some of them. Apr 1, 2015 at 14:18
  • you can delete all the files in var/locks folder and change the permission to 777 for that folder. after that perform reindex by SSH Apr 1, 2015 at 14:19
  • All indexes are in processing state. I already deleted var/locks files and dir permission to 777
    – Sandesh
    Apr 1, 2015 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.