2

I am trying to access system > configuration but I get the following error ~

Fatal error: Class ‘Varien_Data_Form_Element_Color’ not found in /home4/trifect1/public_html/lib/Varien/Data/Form/Abstract.php on line 146

Appreciate any help or advice you can offer me.

Thanks!

  • The error you posted on Twitter suggests a compilation error. Is this s different issue? – philwinkle Jul 31 '13 at 13:31
  • Hello philwinkle, the suggestion above resolved the issue I was having. Thank you! – Sarah Aug 4 '13 at 23:07
3

There is an element in one of your system.xml files that has the type color. This shouldn't be there by default so either you add it or there is an extension that did.
Search in your system.xml files for this piece of text:

<frontend_type>color</frontend_type> 

and remove the field or change the type to text.

  • Hi Marius, thank you for that suggestion. I will try this and get back to you if it solved the issue. – Sarah Jul 31 '13 at 6:20
  • Hello Marius, this suggestion worked and resolved the problem I was having. Thank you! – Sarah Aug 4 '13 at 22:16
  • Same here - that worked. But should I change this file? Does this just come from my installed theme? – Chris Sep 17 '15 at 20:31
  • @Chris. From what I know, this is not present in the core. Most probably comes from a custom extension or theme. So you can edit it. – Marius Sep 18 '15 at 6:24
0

Marius is spot on, here is the file path:

\app\code\local\ThemeOptions\ExtraConfig\etc\system.xml

A custom theme has overwritten this file in my case.

0

I do not have a 50+ Rep so I cannot comment another answer directly, but it is important to confirm that Ray's answer is correct. The -1 rating is unjustified.

Experienced the same error of the OP, caused by a "Varien_Data_Form_Element_Counter" not found (the OP has "Varien_Data_Form_Element_Color"). The offending code was an extension, so I examined its system.xml and files. Recovered file Counter.php from a backup of the extension and put it in /lib/Varien/Data/Form/Element. Problem solved.

-1

I've fixed it by adding "Color.php" file into /lib/Varien/Data/Form/Element Just took it from another installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.