When I try visiting the New Order RSS feed, it returns a 301 redirect (url i'm trying is http://{SITE_NAME}.dev/rss/order/new/ - the redirect sends me straight back the root URL of the store http://{SITE_NAME}.dev/nz/

I've got the same thing happening with MageMonkey too (this uses a /monkey/ URL).

The .htaccess i'm using:

RewriteEngine on
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php [L]
  • Please add more info. Where are you redirected to for example, what is the base url you've stated in the backend of your shop etc. This is too little to go on – Sander Mangel Mar 30 '15 at 9:16
  • Did you try calling http://{SITE_NAME}.dev/nz/rss/order/new/ ? – Sander Mangel Mar 30 '15 at 9:19
  • Ah - that's sorted it. – Te Riu Warren Mar 30 '15 at 9:21
  • Is there any way to configure the feed link URL that shows at the top of the Orders page? It points to the /rss rather than /nz/rss – Te Riu Warren Mar 30 '15 at 9:23
  • Did you turn on Add Store Code to Urls under System > Configuration > Web? And is the Base URL http://{SITE_NAME}.dev/? – Sander Mangel Mar 30 '15 at 9:26

When enabling Add Store Code to Urls under System > Configuration the Admin section might have some issues with that.

I'd advice to turn the option off on the Default Config level only enabling it for the website levels. This way you should be able to call the RSS feed using just the base URL


| improve this answer | |

I had to add the store code to the URL, and i've updated the redirect to redirect the standard link to a store code URL. So http://{SITE_NAME}.dev/rss/order/new/ will redirect to http://{SITE_NAME}.dev/nz/rss/order/new/ and show the RSS page.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.