We are facing an issue with the css styling in Magento store. I tried refreshing the cache in admin but that didn´tt fix the issue.


  • Varnish as external cache
  • Magento
  • Ultimo as the theme

I assume that the theme files are not loading but we are unable to find a correct solution for this.

What steps should we take to resolve this issue?

  • Please provide proper and detailed information about the problem itself and software/version you are using. Otherwise no one will be able to debug this. Commented Mar 26, 2015 at 14:33
  • i solve issue by following techbandhu.wordpress.com/2013/09/12/…
    – matinict
    Commented Feb 8, 2016 at 6:18
  • See by inspect element that the css file are being accessed.
    – Anees
    Commented May 9, 2018 at 15:01

11 Answers 11


If you haven't resolved your issue, open you website -> right click and select view page source or just press CNTRL+U Keys together. There you'll find your styles.css file. Check if it is showing the right url. Click on it, see if it is loading ok.

It should look like this:

<link rel="stylesheet" type="text/css" href="http://www.abcd.com/skin/frontend/rwd/default/css/styles.css" media="all" />

For this problem to happen, There are three reasons I know of:

1.) There might be an issue because of System Cache. Clean the cache from the backend or go to magentoroot/var/ and delete the contents of the cache and session folder.

2.) There can be issue with the file permission of your css File. In this case just type the following command in terminal, sudo chmod 777 -R /magentoroot/

3.) Lastly, there could be something wrong with the url in your core_config_data table of your database, which I think you have already checked.

  • I have slash (/) problem, my styles.css file like <link rel="stylesheet" type="text/css" href="abcd.comskin/frontend/rwd/default/css/styles.css" media="all" /> . There is no slash(/) between domain and skin folder. not only skin folder all my files have no slash(/)
    – zus
    Commented Nov 13, 2017 at 4:59
  • Did you understand my problem?
    – zus
    Commented Nov 13, 2017 at 5:01
  • The missing slash (/) needs to be added to your base_url in the core_config_data table. eg. abcd.com
    – 07lodgeT
    Commented May 21, 2018 at 10:37
  • You are amazing, thanks for that it was driving me nuts
    – Peanuts
    Commented Jan 7, 2019 at 15:45
  • You should never chmod -R 777, thats a big security hole on shared servers!!
    – Black
    Commented Jul 6, 2020 at 9:39

Have you made any recent changes to your database ?

login to your database: find the table named 'core_config_data'

there check the entries against Value:

where path = web/unsecure/base_url and path = web/secure/base_url

see if '/' is missing after the url if yes then put it there.

  • Hi Yugesh, I have checked in the admin and the url is correct with '/' in the end. Commented Mar 27, 2015 at 7:14
  • Have you checked in the table 'core_config_data' ?? Commented Mar 27, 2015 at 9:34
  • Yes I checked in the core_config_data Commented Mar 27, 2015 at 10:36
  • Hi Sai, Have you Resolved Your Problem Yet...? Commented Mar 29, 2015 at 2:53

Adding something to Yugesh M Kumar YO's answer

  1. Check .htaccess file
  2. Disable css merge from core_congif_data

And can you access the admin area without any problem?

If so 3. Check if you have set the design properties correctly. (package, skin, template etc..)

Some more details from your end will help to trap the issue.


In my case it is due to .htaccess file. In my project there is a .htaccess file in /skin folder with following content:

Header set Access-Control-Allow-Origin "*"

I have removed this file and it works fine.


I accidentally deleted the .htaccess files in pub and pub/static After I copied the .htaccess files for these folders from the Magento Github site, the style started to work.


I have the same issue:

enter image description here

I also have both .htaccess (default) in /home/ubuntu/public_html/mangeto-ce-226 and /home/ubuntu/public_html/mangeto-ce-226/pub

I found the question here to help my issue: How to fix Magento 2 2.0.0-RC Admin page not found after installation


edit /etc/apache2/apache2.conf

<Directory /var/www/html> Options Indexes FollowSymLinks MultiViews AllowOverride All allow from all </Directory>

restart Apache : sudo service apache2 restart


you tried to load the css file directly via url and see if you load ok?

You can try to erase the cache Magento cache or jumping, doing this


  • Hi Marc, I refreshed and cleared the cache from admin. I can see the css file loading with the code in it. Commented Mar 26, 2015 at 14:41

if its xampp change in core_config_data web/unsecure/base_url to your address like http://localhost:8080/appname/


Run Command: 1)setup upgrade 2)dicompile 3)static content

it's work for me!


Go to your webroot and execute these two commands:

find . -type d -exec chmod 775 {} \;
find . -type f -exec chmod 664 {} \;

Add Design Change in AdminPanel/System/Design

"Date From" nad "Date To" leave empty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.