For some reason I don't know the attribute option/labels for store view is not working and I don't want to use csv files for translations, therefore I find out that the options are generated by Code/Core/Mage/Catalog/Block/Product/View/Type/Configurable.php

I managed to translate the attribute label by changing the $productAttribute->getLabel() to $productAttribute->getStoreLabel() in line 170

However the attribute options labels are still showing the Global label instead of store view label.

How can make the 'label' => $value['label'] to something like above to show the current store view option label?


1 Answer 1


Question is a little bit older, but i had the same problem! And maybe there are some others :-)

So, my solution:

Go to Catalog -> Manage Products and edit your super product.

Goto Tab Associated products. In Super product attributes configuration check for each configurable attribute the Use default. Then, Magento will use the default translation like normal attributes (which you have to define in Catalog -> Attributes -> Manage Attributes -> Edit Attribute -> Manage Labale/Options.

  • Is there a way to change those automatcally somehow so I would not need to go through all configurable products manually and click them selected?
    – Webninja
    Commented Sep 16, 2015 at 14:19
  • @Webninja Did you solve this issue? I'm also facing the same. Can you please guide?
    – MagentoDev
    Commented Jun 26, 2021 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.