0

Im getting a weird error with some of my magento orders, when a customer runs through the checkout they are required to put a contact number when filling out there delivery details, but for some reason on the back end some orders have contact numbers and some orders don't, this can be very frustrating as we require the contact number to help with the delivery of there items, any ideas why this could be happening?

I have guest checkout enabled, but even that requires you to put in a number.

  • Are there different checkouts? – musicliftsme Mar 21 '15 at 19:14
  • No it's a one page checkout and it's one store. – MrJoshFisher Mar 21 '15 at 19:15
  • Strange. If that's the case, the telephone post data is somehow getting lost. I couldn't tell where it's going wrong. You'll need to identify a case where the number doesn't get saved and trace the steps. Or, it could be somehow the data is in the database but just not getting rendered. Look up an order in sales_flat_order_address and see if the telephone field has anything. – musicliftsme Mar 21 '15 at 19:19
  • It's a little bit weird it works sometimes, I have 2 types of payment options, payment by card, or payment by paypal would paying by paypal effect how the contact number is used. – MrJoshFisher Mar 21 '15 at 19:21
1

Check in all your billing templates (if you've made changes), if you have persistent checkout enabled depending on wether the user has cookies enabled a different template will be shown and depending on wether you use OPC.

So there are the following templates:

app/design/frontend/package/theme/template/checkout/onepage/billing.phtml
app/design/frontend/package/theme/template/persistent/billing.phtml
app/design/frontend/package/theme/template/persistent/checkout/onepage/billing.phtml

That might be the issue?

  • Only edited these to remove company and fax fields but made sure not to touch the telephone number field – MrJoshFisher Mar 20 '15 at 14:01
2

Check if it is PayPal orders affected. If so, I'd suggest you turn on phone numbers required in your PayPal account, as without this PayPal won't share the phone numbers. For most customers PayPal already has their phone number on file so it won't reduce conversions as they say.

Instructions:

  1. Log in to your PayPal account at https://www.paypal.com. Click the Profile subtab, click "profile & Settings" The Profile Summary page appears.
  2. In the Selling Tools column, click the Website Preferences link. Scroll down the page to the Contact Telephone Number section.
  3. Change this to: "On (Required Field)"
  4. Scroll to the bottom of the page and click the Save button.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.