2

Our url is omitting the first '/', like so: ourdomain.comindex.php when it should be ourdomain.com/index.php.

I've looked everywhere in the config, and haven't found a reason why it should be doing that. The base url is ourdomain.com/ in the database, but whenever it is used that trailing backslash is omitted and this causes CSS, JavaScript, basically everything to break.

I've noticed in the config panel, when I switch from 'Default Config' to 'Main Website', this is what the base URL is listed as, instead of the base URL in my 'Default Config' here.

Also, the 'Save Config' button does not seem to be working either, and this whole issue is making me think a re-install is needed.

9
  • What does it say in Configuration-->Web-->Unsecure as Base URL? Could you post a screenshot of that?
    – seb
    Commented Mar 18, 2015 at 15:57
  • Here
    – dhagerty
    Commented Mar 18, 2015 at 16:02
  • Try to to fix it by disabling auto-redirect to base url Or move your installation into a subfolder and change the BaseURL to it that should also work
    – seb
    Commented Mar 18, 2015 at 16:05
  • We're hosting using GoDaddy, is there an easy way to do that with them?
    – dhagerty
    Commented Mar 18, 2015 at 16:23
  • Configuration --> Web --> URL options there is the disabling, maybe try that first
    – seb
    Commented Mar 18, 2015 at 16:29

1 Answer 1

2

It might be because the skin url does not have the trailing / in it. Even when the base url is okey, if the skin url does not have the / you will face this issue.

enter image description here

4
  • He has all these trailing / . It´s just not visible in the screenshot I assume
    – seb
    Commented Mar 18, 2015 at 16:27
  • @Thomas which screenshot?
    – mbalparda
    Commented Mar 18, 2015 at 16:29
  • cl.ly/aGMA?_ga=1.255823360.980251700.1425957135
    – seb
    Commented Mar 18, 2015 at 16:30
  • Yes, all the trailing slashes are there.
    – dhagerty
    Commented Mar 18, 2015 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.