1

I have same exact problem as https://magento.stackexchange.com/questions/58201/configurable-product-not-showing-in-magento.

  1. Make configurable product "In Stock"

  2. Use "Quick simple product creation" to generate simple products "enabled" "not individually visable" "in stock" "qty > 0"

They do not show up in "Super product attributes configuration" section

It appears that they do not get 'associated'

I have tried regenerating all indexes, flushing all caches numerous times.

Once in a while if I start from scratch, the associated products will show up, but 5 out of 6 times ... it won't work.

  • 1
    This happens with one attribute set that contains an added attribute "group" with 3 attributes. All the 3 attributes are set to dropdown, use to create configurable product, global. Magento lets me create "Quick simple product creation" from the configurable product, and I save. The simple products are there, but are NOT associated ! – Allen Mayers Mar 18 '15 at 14:08
2

Adding the author's comment as an answer to not leave this "unanswered":

This happens with one attribute set that contains an added attribute "group" with 3 attributes. All the 3 attributes are set to dropdown, use to create configurable product, global. Magento lets me create "Quick simple product creation" from the configurable product, and I save. The simple products are there, but are NOT associated !

I am not sure if this really answers the question, but there seems to be a bug related to attribute groups

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.